PowerFlex 从 3.x 升级到 4.x 失败,数据库备份由于 ElasticSearch 问题而失败

Summary: 本文介绍如何解决由于备份失败和 ElasticSearch 问题而导致的从 3.x 升级到 4.x 的失败问题。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

从 3.x 到 4.x 的 PowerFlex 升级失败 在导入过程中,将触发旧 PowerFlex 3.8.3 的数据库备份并失败。

 

2025-05-21 15:10:06,299 INFO [backup-1,tid=252] (BackupApplianceCallable.java:216): Executing the script: /opt/Dell/scripts/backup-elasticsearch.py
2025-05-21 15:10:16,779 DEBUG [backup-1,tid=252] (ExecuteSystemCommands.java:103): Last login: Wed May 21 15:10:01 CEST 2025 on cron
2025-05-21 15:10:16,780 ERROR [backup-1,tid=252] (ExecuteSystemCommands.java:127): Non-zero return code running OS command /usr/bin/sudo /opt/Dell/scripts/backup-elasticsearch.py: 3
2025-05-21 15:10:16,781 ERROR [backup-1,tid=252] (ExecuteSystemCommands.java:128): Console output running OS command: Last login: Wed May 21 15:10:01 CEST 2025 on cron
2025-05-21 15:10:16,781 ERROR [backup-1,tid=252] (BackupApplianceCallable.java:225): Error executing the script /opt/Dell/scripts/backup-elasticsearch.py: rc=3
2025-05-21 15:10:16,781 ERROR [backup-1,tid=252] (BackupApplianceCallable.java:246): Unable to backup the database. com.dell.asm.i18n2.exception.AsmCheckedException: The appliance cannot be backed because of an unknown exception.
2025-05-21 15:10:16,785 INFO [backup-1,tid=252] (BackupApplianceCallable.java:73): Executing the script /opt/Dell/scripts/backup-clean.sh

 

ASM 管理器日志
 

Line 16272: 2025-05-21 11:32:50,308 DEBUG [backup-1,tid=245] (ExecuteSystemCommands.java:103): rm: cannot remove ‘/var/es-backup/indices’: Directory not empty
Line 16276: 2025-05-21 11:32:50,315 ERROR [backup-1,tid=245] (ExecuteSystemCommands.java:128): Console output running OS command: rm: cannot remove ‘/var/es-backup/indices’: Directory not emptyCleanup of /var/es-backup failed with RC=1Last login: Wed May 21 11:32:35 CEST 2025
Line 18203: 2025-05-21 12:02:54,161 DEBUG [backup-1,tid=245] (ExecuteSystemCommands.java:103): rm: cannot remove ‘/var/es-backup/indices’: Directory not empty
Line 18207: 2025-05-21 12:02:54,165 ERROR [backup-1,tid=245] (ExecuteSystemCommands.java:128): Console output running OS command: rm: cannot remove ‘/var/es-backup/indices’: Directory not emptyCleanup of /var/es-backup failed with RC=1Last login: Wed May 21 12:02:37 CEST 2025

Cause

ElasticSearch 数据存在问题  

Resolution

命令使用 delladmin 帐户在 PowerFlex Manager CLI 上运行。

 

步骤 1 = 释放弹性搜索数据库中的空间(最大大小应为 5G)

   

  • curl 'localhost:9200/_cat/indices?v’

 

如果有许多 snmp 陷阱索引,则可以删除较旧的陷阱(如果您同意):

 

  • curl -X DELETE localhost:9200/snmp-traps-YYYY.MM.DD (this deletes a specific date)

 

或者,您可以通过以下命令将它们全部删除:

 

  • curl -X DELETE 'http://localhost:9200/syslog* [localhost]'

 

步骤 2 = 删除弹性搜索日志。

  • sudo systemctl status Elasticsearch
    sudo systemctl stop Elasticsearch
    
    cd /var/log/elasticsearch (note: Do not delete vxfm-es-cluster.log)
    rm -rf *log.gz*
    rm -rf *gc.log*
    rm -rf *showlog.log*
    
    Systemctl start Elasticsearch
    sudo systemctl status Elasticsearch


步骤 3 = 删除 ElasticSearch 中的所有数据:

*警告:客户将丢失所有历史警报、资源的性能指标以及系统日志数据。

 

  • curl -XDELETE localhost:9200/_all

 

检查状态并停止 rsyslog 服务。

 

systemctl status rsyslog

systemctl stop rsyslog

 

请重试并启动系统日志服务:

systemctl start rsyslog

 

 

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000323551
Article Type: Solution
Last Modified: 19 Jun 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.