Dell Unity: Pool Space Utilization Reached 95 Percent
Summary: Unisphere reports an alert that "pool space utilization has reached 95% on your Dell Unity storage system". Pools exceeding the 90% threshold can cause degraded performance or inability to allocate new storage. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Multiple alerts can indicate this pool space issue:
Automatic snapshot deletion paused, because the storage pool could not reach the pool-used-space high threshold.This storage pool has exceeded the capacity threshold you specified. To allocate more storage space, add additional disks to your system.Pool space utilization has reached 95%
Cause
Accumulated snapshots and oversubscription consume significant space over time, causing high pool utilization.
Resolution
The file systems (FS), Logical Unit Numbers (LUN), and snapshots need free space in the pool in order to properly perform. This is done by expanding the impacted pool.
If the impacted pool cannot be expanded, then free space must be made in the pool by one of the following methods:
- Delete snapshots
- Expand the storage pool (using existing drives or purchasing additional drives if there are slots available)
- Remove unneeded resources (LUN or FS)
- Run the space reclaim procedure (from the host-side) to potentially free-up space which has not been zeroed-out on the array side
- Reclaiming VMFS deleted blocks on Thin Provisioned LUNs (external link)
- Investigate preallocated space concerns
Additional Tips
- Automate snapshot deletion: Set retention policies to automatically delete old snapshots.
- Review snapshot schedules: Avoid overly frequent snapshot creation.
- Enable alerts: Configure alerts for pool usage thresholds (for example, 80%, 90%) to act proactively.
Related Documents:
Related Dell Knowledgebase Articles:
- Dell Unity: Automatic Snapshot Deletion Becomes Paused
- Dell Unity: Storage Processor Panic During A Pool Full Event
If further help is needed, contact Dell Technical Support and reference this Dell Knowledgebase Article.
Additional Information
How to Delete Unnecessary Snapshots
Step 1: Check Pool Usage:
- Unisphere:
- Storage > Pools
- Select the affected pool and review the
Used (%)column. - Click the pool name to view detailed usage, including space used by snapshots.
- CLI:
- Log in to putty with service credentials.
- Run command:
uemcli -d 10.0.0.1 -u Local/joe -p MyPassword456! /stor/config/pool show -detail
Step 2: Identify Large or Old Snapshots:
- Unisphere:
- Storage > Block > LUNs or Storage > File > File Systems
- For each LUN or file system, check the Snapshots tab.
- CLI:
- Log in to putty with service credentials.
- Run command to see snapshot details:
uemcli -d 10.0.0.1 -u Local/joe -p MyPassword456! /prot/snap show -detail - Run command to see snapshot space used by individual storage resource:
uemcli -d 10.0.0.1 -u Local/joe -p MyPassword456! /stor/config/pool/sr -pool <pool name> show -detail Example:
uemcli -d 10.0.0.1 -u Local/joe -p MyPassword456! /stor/config/pool/sr -pool pool_1 show -detail
ID = sv_1
Name = AF LUN 1
Resource type = LUN
Pool = pool_1
Total pool space used = 14448566272 (13.4G)
Total pool preallocated = 4610351104 (4.2G)
Total pool snapshot space used = 4593991680 (4.2G)
Total pool non-base space used = 4593991680 (4.2G)
Health state = OK (5)
Health details = "The LUN is operating normally. No action is required."
Step 3: Delete Snapshots:
⚠️ Caution: Ensure that the snapshots are not required for backup or recovery before deletion. ⚠️
- Unisphere:
- Select one or more snapshots to delete.
- Click Delete and confirm the action.
- Repeat for other LUNs or FSs as needed.
- CLI:
- Run command:
uemcli -d 10.0.0.1 -u Local/joe -p MyPassword456! /prot/snap –id <Snapshot ID> delete
- Run command:
Step 4: Monitor Pool Usage:
- Unisphere:
- After one or more snapshots are deleted, return to Storage > Pools.
- Refresh the page and monitor the
Used (%)value. - It may take a few minutes for the space to be reclaimed.
- CLI:
- Run command:
uemcli -d 10.0.0.1 -u Local/joe -p MyPassword456! /stor/config/pool show -detail
- Run command:
Affected Products
Dell EMC Unity, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity HybridArticle Properties
Article Number: 000343406
Article Type: Solution
Last Modified: 06 Nov 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.