NVP-vProxy: Clone action fails with no available devices to clone

Summary: The VMware backup action completes successfully, but the clone action fails with no available devices.

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Symptoms

The NetWorker VMware Protection integration is configured with the vProxy Appliance. The VMware backup action completes successfully, but the clone action fails with no available devices. The clone action completed successfully in the past and there have been no recent changes. The clone action log information shows:
MM/DD/YYYY HH:MM:SS [NETWORKER_SERVER] nsrclone NSR notice Action clone '[CLONE_ACTION_NAME]' has initialized as 'clone job' with job id [JOBID] 
MM/DD/YYYY HH:MM:SS [NETWORKER_SERVER] nsrclone NSR notice There is no availabe devices to clone! just skip all savests! 
MM/DD/YYYY HH:MM:SS [NETWORKER_SERVER] nsrclone NSR critical No valid backend job 
MM/DD/YYYY HH:MM:SS [NETWORKER_SERVER] nsrclone NSR notice Action clone '[CLONE_ACTION_NAME]' with job id [JOBID] is exiting with status 'failed', exit code 1 
MM/DD/YYYY HH:MM:SS [NETWORKER_SERVER] nsrclone NSR critical NSRCLONE failed for one or more savesets.

Cause

The Disk Volume mode is not configured for the volumes in the target clone pool. The Disk Volume mode must be set to "Appendable" for the volume to be available for the clone action. The reason for the Disk Volume mode not having a configuration is unknown.
 

Resolution

The Disk Volumes in the target clone pool must be updated to reflect "Appendable."  Here is an overview of the steps to update the volume mode.

  • Open the NetWorker Management Console (NMC).
  • Select the "Media" Tab.
  • In the left hand tree view, select "Disk Volumes."
  • In the right-hand pane, select one of the volumes in the target clone pool.
  • Right click the volume and select "Change mode."
  • In the Change Mode properties window, select "Appendable" and then "OK."
  • Change the mode for any other volumes in the target clone pool.

Affected Products

NetWorker Management Console
Article Properties
Article Number: 000065191
Article Type: Solution
Last Modified: 27 Oct 2025
Version:  5
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