Dell Unity: Management IP address with new subnet cannot be assigned (User Correctable)
Summary: A system is either having its Management IP address configured during deployment or having the management IP address subnet changed. When a gateway is chosen, if the Subnet ID is used the Management IP configuration fails. This can occur either within Unisphere or at the command line. An error is seen about a failure to change the management IP configuration in Unisphere and also at the command line. Both Unisphere and the command line will be unable to be logged into. Access from ipmitool on either SP must be used to continue and resolve the issue. ...
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Symptoms
An error is seen about not being able to change the Management IP with new subnet/gateway in Unisphere or the ssh command line.
Note: Both Unisphere and the command line will be unable to be logged into. Access from ipmitool on either SP must be used to continue and resolve the issue.
Article 000022376 describes use of ipmitool.
https://www.dell.com/support/kbdoc/en-us/000022376/dell-emc-unity-using-the-ipmitool-on-unity-systems
A check of the output of the command: svc_diag from the ssh shell shows no IP address configured for Management.
Using the command below to check the configuration below will not show any valid info.
Command: uemcli /net/if/mgmt show
A valid configuration however shows the normal output. Notice the .128 Subnet mask.
The following command was used to set the management address for a newly deployed system in this case, but it failed.
friendlyname = name of the Unity system that is wanted
Note: Both Unisphere and the command line will be unable to be logged into. Access from ipmitool on either SP must be used to continue and resolve the issue.
Article 000022376 describes use of ipmitool.
https://www.dell.com/support/kbdoc/en-us/000022376/dell-emc-unity-using-the-ipmitool-on-unity-systems
A check of the output of the command: svc_diag from the ssh shell shows no IP address configured for Management.
Using the command below to check the configuration below will not show any valid info.
Command: uemcli /net/if/mgmt show
A valid configuration however shows the normal output. Notice the .128 Subnet mask.
uemcli /net/if/mgmt show Storage system address: 127.0.0.1 Storage system port: 443 HTTPS connection 1: IP protocol version = ipv4 Address origin = static IP address = 10.241.219.230 Subnet mask = 255.255.255.128 Gateway = 10.241.219.129--------------------------------------------------------------------------------------------------------------------------------------------------------
The following command was used to set the management address for a newly deployed system in this case, but it failed.
svc_initial_config -f friendlyname -4 "10.242.12.18 255.255.255.240 10.242.12.16"
friendlyname = name of the Unity system that is wanted
Cause
When changing the management IP address subnet with a new or changed gateway, it was found that an invalid gateway was chosen.
The gateway used was actually the ID of the subnet (all 0 in hostbits). The subnet ID is invalid and cannot be used as a gateway per networking rules.
Two special addresses in every subnet cannot be used as endpoints:
The gateway used was actually the ID of the subnet (all 0 in hostbits). The subnet ID is invalid and cannot be used as a gateway per networking rules.
Two special addresses in every subnet cannot be used as endpoints:
- The first (lowest) address is the network identifier (subnet ID)
- The last (highest) address is the subnet broadcast address.
Resolution
A valid gateway IP address must be chosen which allows successful configuration of the Management IP address. Once configured Unisphere can be used again for login.
Affected Products
Dell EMC UnityArticle Properties
Article Number: 000215565
Article Type: Solution
Last Modified: 26 Oct 2023
Version: 4
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