Сбой проверки состояния каталога корзины Isilon PowerScale

Summary: Сбой проверки работоспособности каталога корзины во время ежедневной диагностики системы.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Сбой проверки работоспособности каталога trash_dir_pq_limit корзины.

Cause

Проверка работоспособности каталога корзины завершается сбоем, если в каталоге корзины накапливается более 10 240 записей. Этот сбой проверки работоспособности может быть вызван множеством проблем, связанных с состоянием службы каталогов корзины, включая, помимо прочего, следующее: - 

(1) Служба каталогов корзины перестала работать (сбой, зависание или отключение) или не удалось удалить устаревшие записи PQ каталога корзины. 

(2) Сбой/зависание или отключение привилегированным пользователем таких сервисов OneFS, как isi_job_d, isi_papi_d или TreeDelete .  

(3) Потребительские службы корзины активно удаляют каталоги в корзине или в настоящее время выполняют задания, блокируя удаление каталогов, в которых они находятся.  

Resolution

Эта статья базы знаний будет обновлена после того, как будет доступно любое исправление. 

Решение:
Приведенные ниже временные решения должны быть полезны в соответствии с тремя упомянутыми выше категориями причин.  

(1) MCP должен перезапустить службу при сбое службы каталогов корзины. Исправьте ошибки, которые могут быть вызваны зависанием службы каталогов корзины. Если служба каталога корзины зависла, ее можно остановить или перезапустить для временного решения. Сбой проверки работоспособности каталога корзины можно игнорировать, если isi_trash_d служба каталогов корзины была отключена привилегированным пользователем. Однако при необходимости эту услугу необходимо активировать, чтобы служба каталогов корзины удаляла каталоги в корзине.  
 

isi services -a isi_trash_d enable 


 
Выполните следующую команду, чтобы удалить устаревшие записи PQ, если служба каталогов корзины не укатит устаревшие записи в PQ. 
 

/usr/libexec/isilon/isi_trash_pq_clean --cleanup [--debug] 

 

Также убедитесь, что интервал запроса состояния задачи для заданий TreeDelete в очереди службы не превышает 30 секунд в указанном выше случае. 

 

isi_gconfig -t trash-config job_query_interval=30 

 

(2) Если сервисы OneFS магистральной сети или задание TreeDelete зависло или отключено привилегированным пользователем, сбой healthCheck каталога корзины можно игнорировать. Тем не менее, службы OneFS магистрали или задача TreeDelete должны быть включены при необходимости, чтобы служба каталогов корзины мог завершить удаление каталогов в корзине.  
 

(3) Сбой проверки работоспособности каталога корзины можно игнорировать, если потребительские службы (снимок переноса данных Lhotse или Writable) активно удаляют каталоги в корзине или в настоящее время выполняют задания, блокируя удаление корзины каталогов. В этом случае сервисы OneFS магистрали являются узким местом. 
Если задания TreeDelete, которые в течение длительного времени поставлены в очередь службой каталогов корзины, блокируют обработку существенного количества недавно размежаемых каталогов, то можно настроить для задач TreeDelete, которые поставлены в очередь службой, меньшее значение можно настроить. Минимальные рекомендуемые значения для этих tunables: - 
 

isi_gconfig -t trash-config job_timeout_limit=3600 
isi_gconfig -t trash-config job_query_interval=30 


 
Обратите внимание, что служба каталогов корзины отменяет задачу TreeDelete, поставленную в очередь службой, которая все еще запущена или приостановлена после ограничения времени ожидания задания. Таким образом, если услуга отменяет большинство заданий TreeDelete, которые были поставлены в очередь самостоятельно, лимит тайм-аута задания может быть увеличен до более высокого значения. 

Affected Products

Isilon, PowerScale OneFS
Article Properties
Article Number: 000196018
Article Type: Solution
Last Modified: 29 Jun 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.