Integrated Data Protection Appliance: Problemas de Acesso Intermitente e Falhas de SSO ao aceder a DPC com credenciais AD/LDAP após a atualização da versão 2.7.6.

Summary: Após a atualização do IDPA 2.7.6/atualização do DPC 19.9, o DPC mostra problemas com o acesso e o SSO ao tentar fazê-lo com credenciais AD/LDAP.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Erro da DPC
  • A origem AD/LDAP é configurada no DPC e, ao tentar acessar o DPC usando credenciais AD/LDAP, ele falha intermitentemente com esse erro, às vezes funciona. Ainda mais, se os cookies e o cache forem limpos, no entanto, esta não é uma solução permanente. 
  • Ao ser registado com credenciais AD/LDAP, o SSO para sistemas integrados no DPC falharia com o mesmo erro. 
  • As ferramentas de desenvolvedor mostram um erro 502 bad gateway. 
O erro abaixo é visto na error.log nginx. 
2024/04/09 10:53:10 [error] 64587#64587: *14150 upstream sent too big header while reading response header from upstream, client: 172.26.130.97, server: xxxxx.xxxxx.xxxxx request: "GET /auth/realms/DPC/protocol/openid-connect/authscope=openid+profile&response_type=code&redirect_uri=https%3A%2F%2Fxxxxx.xxxxx.xxxxx&state=YWK9IJANc0Tn9c8dhSA_MAOfja3DSairR_Ag8kLker4&nonce=uPOO0ZLBU9WzHhuaR45e6q7PqYCbYOEi8Kk5sttJA5I&client_id=98ce7c21-0ec2-4d9b-9bde-125d940f212f HTTP/1.1", upstream: "https://127.0.0.1:8143/auth/realms/DPC/protocol/openid-connect/auth?scope=openid+profile&response_type=code&redirect_uri=https%3A%2F%2Fmin-dp-idpa01-dpc-01.vcdservices.local&state=YWK9IJANc0Tn9c8dhSA_MAOfja3DSairR_Ag8kLker4&nonce=uPOO0ZLBU9WzHhuaR45e6q7PqYCbYOEi8Kk5sttJA5I&client_id=98ce7c21-0ec2-4d9b-9bde-125d940f212f", host: "xxxxx.xxxxx.xxxxx", referrer: "https://xxxxx.xxxxx.xxxxxx/"

Cause

Quando o NGINX processa os cabeçalhos de resposta, ele define um limite no tamanho dos cabeçalhos que pode manipular. Se os cabeçalhos excederem esse limite, NGINX rejeita a conexão e isso resulta em um erro de gateway incorreto 502. 

Resolution

1. No arquivo etc/nginx/nginx.conf, adicione as linhas abaixo depois que keepalive_timeout variável for definida.

    proxy_buffer_size   128k;
    proxy_buffers   4 256k;
    proxy_busy_buffers_size   256k;

2. Guarde esta configuração.
3. Reiniciar o serviço nginx

service nginx restart

4. Teste-o novamente se o comportamento mudar.

Affected Products

Data Protection Central
Article Properties
Article Number: 000225360
Article Type: Solution
Last Modified: 27 May 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.