Integrated Data Protection Appliance (IDPA) Problèmes d’accès intermittent et défaillances de SSO lors de l’accès à DPC avec les informations d’identification AD/LDAP après la mise à niveau de la version 2.7.6.
Summary: Après la mise à niveau IDPA 2.7.6/la mise à niveau de DPC 19.9, DPC affiche des problèmes d’accès et d’authentification unique lors de la tentative d’exécution avec les informations d’identification AD/LDAP. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- La source AD/LDAP est configurée dans DPC et lorsque vous tentez d’accéder à DPC à l’aide des informations d’identification AD/LDAP, elle échoue par intermittence avec cette erreur. Parfois, cela fonctionne. De plus, si les cookies et le cache sont effacés, il ne s’agit pas d’une solution permanente.
- Lors de la connexion avec les informations d’identification AD/LDAP, l’authentification unique sur les systèmes intégrés à DPC échoue avec la même erreur.
- Les outils de développement affichent une erreur de passerelle incorrecte 502.
2024/04/09 10:53:10 [error] 64587#64587: *14150 upstream sent too big header while reading response header from upstream, client: 172.26.130.97, server: xxxxx.xxxxx.xxxxx request: "GET /auth/realms/DPC/protocol/openid-connect/authscope=openid+profile&response_type=code&redirect_uri=https%3A%2F%2Fxxxxx.xxxxx.xxxxx&state=YWK9IJANc0Tn9c8dhSA_MAOfja3DSairR_Ag8kLker4&nonce=uPOO0ZLBU9WzHhuaR45e6q7PqYCbYOEi8Kk5sttJA5I&client_id=98ce7c21-0ec2-4d9b-9bde-125d940f212f HTTP/1.1", upstream: "https://127.0.0.1:8143/auth/realms/DPC/protocol/openid-connect/auth?scope=openid+profile&response_type=code&redirect_uri=https%3A%2F%2Fmin-dp-idpa01-dpc-01.vcdservices.local&state=YWK9IJANc0Tn9c8dhSA_MAOfja3DSairR_Ag8kLker4&nonce=uPOO0ZLBU9WzHhuaR45e6q7PqYCbYOEi8Kk5sttJA5I&client_id=98ce7c21-0ec2-4d9b-9bde-125d940f212f", host: "xxxxx.xxxxx.xxxxx", referrer: "https://xxxxx.xxxxx.xxxxxx/"
Cause
Lorsque NGINX traite les en-têtes de réponse, il définit une limite sur la taille des en-têtes qu’il peut gérer. Si les en-têtes dépassent cette limite, NGINX rejette la connexion, ce qui entraîne une erreur de passerelle incorrecte 502.
Resolution
1. Dans le fichier etc/nginx/nginx.conf, ajoutez les lignes ci-dessous une fois keepalive_timeout variable définie.
proxy_buffer_size 128k; proxy_buffers 4 256k; proxy_busy_buffers_size 256k;
2. Enregistrez cette configuration.
3. Redémarrer le service nginx
service nginx restart
4. Testez-le à nouveau si le comportement change.
Affected Products
Data Protection CentralArticle Properties
Article Number: 000225360
Article Type: Solution
Last Modified: 27 May 2024
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.