Secure Connect Gateway - Changing HTTP proxy credentials is not effective on gateways upgraded from SRS 3.52
Summary: This article explains why changing HTTP proxy credentials is not effective on gateways upgraded from SRS 3.52.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Attempting to change the proxy credentials after migrating from SRS 3.52 to SCG 5.20 (which is the only migration path supported), causes loss of connectivity between the gateway and Dell.
Cause
The issue happens only in the case when the proxy credentials are updated following a SRS 3.x to SCG 5.20 migration. The Mosquitto.service was seen to be taking the password configured in the mosquito.conf file rather than the credentials stored in the LockBox. It was observed that the updated credentials are being stored in the Lockbox, but mosquitto.conf is not updated. Since precedence for the password is the mosquito.conf file, the old credentials were being used.
Resolution
Upgrade the SCG gateway from 5.20 to a later version, which will remove the old credentials from mosquitto.conf.
Alternatively, if the gateway needs to remain on v5.20, use the following steps:
Alternatively, if the gateway needs to remain on v5.20, use the following steps:
- Apply new credentials from the SCG WebUI once again, while it is connected.
- SSH to the SCG-VE and login as root.
- Enter the SRS container using
docker exec -it esrsde-app bash
- Comment out password from mosquitto.conf by using below command
-
sed -i 's/proxy_password/#proxy_password/g' /etc/mosquitto/conf.d/mosquitto.conf
- Restart the Mosquitto service:
wd stop esrsmosquitto wd start esrsmosquitto
- Logout of the container, and SSH session:
exit exit
- Once the above steps are applied, the credentials will be taken from the Lockbox.
Products
Secure Connect Gateway, Secure Connect Gateway, Secure Connect Gateway - Virtual EditionArticle Properties
Article Number: 000227392
Article Type: Solution
Last Modified: 02 Aug 2024
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.