PowerScale: WebUI frequently logs out when connected using SmartConnect FQDN
Summary: This article summarizes issues when using the WebUI with a SmartConnect zone name.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
NOTE: OneFS 9.4 and later includes the ability to use the SmartConnect zone name to the cluster's WebUI as sessions can move between nodes.
Administrators frequently reenter credentials to maintain WebUI sessions.
When logging into the OneFS WebUI using the SmartConnect zone name, the administrator is asked to reenter credentials. This issue can present in a few ways:
Administrators frequently reenter credentials to maintain WebUI sessions.
When logging into the OneFS WebUI using the SmartConnect zone name, the administrator is asked to reenter credentials. This issue can present in a few ways:
- The administrator is unexpectedly returned to the login page when browsing the WebUI
- The administrator may be sitting on a page and redirected back to the login page
- The administrator may be frequently asked to reenter credentials by the browser
- The administrator may enter correct credentials and be redirected almost immediately back to the login page.
Cause
The OneFS WebUI does not support multinode sessions. When connected to a SmartConnect zone name the session may be routed to another node unexpectedly. The administrator may see log messages like the following.
2015-05-05T22:23:41-08:00 <12.3> mycluster-1(id1) httpd[1234]: [error] [client 1.1.1.1] (401) Session is invalid., referer: https://SmartConnectFQDN:8080/OneFS
2015-05-06T15:08:53-08:00 <12.3> mycluster-1(id1) httpd[1234]: [error] [client 1.1.1.1] (401) Session is invalid., referer: https://SmartConnectFQDN:8080/OneFSResolution
Log in to the OneFS WebUI using an IP address assigned to one node (NOT the SmartConnect IP address). Or utilize a DNS name that points to only one IP address of a node.
In OneFS 9.4 and later, OneFS now features using the FQDN for the WebUI as sessions can move between nodes.
Affected Products
PowerScale OneFSProducts
PowerScale OneFSArticle Properties
Article Number: 000040840
Article Type: Solution
Last Modified: 29 Dec 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.