SourceOne Email Management: Outlook connection fails for RPC/HTTP in mixed mode environment.

Summary: SourceOne Email Management: Outlook connection fails for RPC/HTTP in mixed mode environment.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



When attempting to configure RPC over HTTP, unable to do so.

The environment is Mixed Microsoft Exchange (2010 and 2016).

Have already followed the KB article 498673: SourceOne Email Management: Message: You are unable to connect to a Microsoft Exchange 2016 Journal mailbox in a mixed Microsoft Exchange (2010 and 2016) environment which explains prerequisite for mixed mode and also KB article 492309: SourceOne Email Management: SourceOne account ca not access end users mailboxes while running activities. which uses RPC/HTTP protocol instead of MAPI/HTTP protocol when connecting the Outlook SourceOne profile with the Exchange server.

After following these two KBs, the user is unable to use the RPC/ HTTP connection to exchange and the SourceOne jobs still fail showing an established connections using only HTTP instead of the required RPC.

Cause

This  issue is caused by a parameter setting on the Exchange server side blocking RPC over HTTP on all mailboxes.

MAPIBlockOutlookRpcHttp: True

Resolution

The following flag is set to block RPC over HTTP on all the exchange mailboxes.

MAPIBlockOutlookRpcHttp: True

Changing this flag to false resolves the issue after re starting Outlook. Consult exchange documentation in order to change this value if unsure.

kA23a0000000AaWCAU_2_0

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000082043
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.