NetWorker: SQL Server Logs backup for a restored database fails: secondary replica failed

Summary: NetWorker Module for Microsoft (NMM) SQL Server logs backup fails. This occurs when a database has been recently restored and the SQL Server AlwaysOn Availability Group (AAG) backup preference is set to "secondary." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Module for Microsoft (NMM) SQL Server logsonly backup fails.
This occurs when the following conditions are true:

  • The SQL Server AlwaysOn Availability Group (AAG) backup preference is set to "secondary."
  • A SQL database has been recently restored and added to the AAG

The symptoms include:

  • The first Logsonly backup of the restored database backup promotes to level full and completes successfully
  • The second Logsonly backup fails with the following error:
    Log backup for database "aogdbcopy" on a secondary replica failed because a synchronization point could not be established on the primary database. 
    Either locks could not be acquired on the primary database or the database is not operating as part of the availability replica. 
    Check the database status in the SQL Server error log of the server instance that is hosting the current primary replica. 
    If the primary database is participating in the availability group, retry the operation.

 

Cause

The root cause of this issue is that the database was recently restored and added to the AAG, but a full backup cycle was not started on the primary node of the AAG.

 

Resolution

To resolve this issue:

  • Open SQL Server Management Studio, and edit the Availability Group properties
  • Set the AAG backup preference to primary
  • Run a NetWorker level full backup for the restored database
  • Run a NetWorker level Logsonly backup for the restored database
  • Set the AAG backup preference to secondary
  • Run a NetWorker level Logsonly backup again

 

Article Properties
Article Number: 000218527
Article Type: Solution
Last Modified: 18 Feb 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.