NetWorker: 복원된 데이터베이스에 대한 SQL Server 로그 백업 실패: 보조 복제본 실패

Summary: NMM(NetWorker Module for Microsoft) SQL Server 로그 백업이 실패합니다. 이 상태는 데이터베이스가 최근에 복원된 경우에 발생합니다 SQL Server AAG(AlwaysOn Availability Group) 백업 기본 설정이 "보조"로 설정되어 있습니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NMM(NetWorker Module for Microsoft) SQL Server 로그 전용 백업이 실패합니다.
이 문제는 다음과 같은 경우에 발생합니다.

  • SQL Server AAG(AlwaysOn Availability Group) 백업 기본 설정이 "보조"로 설정되어 있습니다.
  • SQL 데이터베이스가 최근에 복원되어 AAG에 추가되었습니다.

증상은 다음과 같습니다.

  • 복원된 데이터베이스 백업의 첫 번째 Logsonly 백업이 전체 레벨로 승격되고 성공적으로 완료됩니다
  • 두 번째 Logsonly 백업이 실패하고 다음 오류가 발생합니다.
    Log backup for database "aogdbcopy" on a secondary replica failed because a synchronization point could not be established on the primary database. 
    Either locks could not be acquired on the primary database or the database is not operating as part of the availability replica. 
    Check the database status in the SQL Server error log of the server instance that is hosting the current primary replica. 
    If the primary database is participating in the availability group, retry the operation.

 

Cause

이 문제의 근본 원인은 데이터베이스가 최근에 복원되어 AAG에 추가되었지만 AAG의 기본 노드에서 전체 백업 주기가 시작되지 않았기 때문입니다.

 

Resolution

이 문제를 해결하려면 다음 단계를 수행하십시오.

  • SQL Server Management Studio를 열고 가용성 그룹 속성을 편집합니다
  • AAG 백업 기본 설정을 기본으로 지정
  • 복원된 데이터베이스에 대해 NetWorker 레벨 전체 백업 실행
  • 복원된 데이터베이스에 대해 NetWorker 레벨 Logsonly 백업 실행
  • AAG 백업 기본 설정을 보조로 지정
  • NetWorker 레벨 Logsonly 백업을 다시 실행

 

Article Properties
Article Number: 000218527
Article Type: Solution
Last Modified: 18 Feb 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.