PPDM - Restore della VM con riconoscimento dell'applicazione non riuscito con il messaggio "Unable to reset disks to read/write mode after VSS quiesce operation set them to read-only"

Summary: Il restore della VM con riconoscimento dell'applicazione non è riuscito con "Unable to reset disks to read/write mode after VSS quiesce operation set them to read-only" a causa della mancanza di memoria sul nodo di ricerca. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ripristino delle VM con riconoscimento dell'applicazione di PowerProtect Data Manager non riuscito con messaggio di errore
Unable to reset disks to read-write mode after VSS quiesce operation set them to read-only

In "PowerProtect Data Manager_*******.log"
vmdm.log: 2024-06-19T01:51:39.916Z ERROR [] [request-dispatch-update-91] [00000000-0000-4000-a000-000000000000][][][TRACE_ID:b78abd00d05a58d4;JOB_ID:af29df7e344de2ee][] [c.e.b.v.r.a.BaseRestoreOp.doFailureStatus(561)] -  Recover VM failed.
vmdm.log: 2024-06-19T01:51:39.917Z ERROR [] [request-dispatch-update-91] [00000000-0000-4000-a000-000000000000][][][TRACE_ID:b78abd00d05a58d4;JOB_ID:af29df7e344de2ee][] [c.e.b.v.r.a.BaseRestoreOp.getSessionError(740)] -  VM Proxy restore job session failed. Session '8fbda571-ab2d-4597-8fe7-4791993b836d' is unsuccessful: Unable to reset disks to read-write mode after VSS quiesce operation set them to read-only.

Vmdirect_******.log riportato di seguito con l'AVVERTENZA, che indica la mancanza di memoria, prima di generare l'ERRORE per reimpostare i dischi in modalità di lettura/scrittura.
    2024-06-19 09:36:57+0800    164     WARNING ppdm.local      58736   processmanager.go(336)  main.(*ProcessManager).isThresholdMemoryConsumptionReached      Available system memory (364 MB) is less than minimum required system resources (800 MB)
    2024-06-19 09:36:57+0800    165     WARNING ppdm.local      58736   processmanager.go(251)  main.(*ProcessManager).waitForCurrentSearchClientProcessesToComplete    Max number of vm-file-extractor processes are running.  Cancelling run of vm-file-extractor for vm EC020DB01 after 10 minutes
    2024-06-19 09:36:57+0800    166     WARNING ppdm.local      58736   main.go(323)    main.main       Max number of vm-file-extractor processes are running. Cancelling the process after 10 minutes as not enough system resources are available. The metadata extraction and indexing of this VM will be handled later by the offline-indexing process.
    2024-06-19 09:36:57.001+0800        167     ERROR   ppdm.local      58736   main.go(838)    main.exitWithError      abort extraction with Max number of vm-file-extractor processes are running. Cancelling the process after 10 minutes as not enough system resources are available. The metadata extraction and indexing of this VM will be handled later by the offline-indexing process.
    2024-06-19 09:36:57.001+0800        169     ERROR   ppdm.local      58736   main.go(848)    main.exitWithError      {"State":"Skipped","Error":"Max number of vm-file-extractor processes are running. Cancelling the process after 10 minutes as not enough system resources are available. The metadata extraction and indexing of this VM will be handled later by the offline-indexing process.","LogFile":"","DetailedStatus":"{\"State\":\"Skipped\",\"Error\":\"\",\"DiskStatus\":[]}"}
    2024-06-19 09:36:57.001+0800        170     ERROR   ppdm.local      58736   main.go(855)    main.exitWithError      abort extraction of VM metadata for asset EC020DB01 (vm-53132)
RecoverVmSessions-b1d958e1-f05b-46a8-af3c-d7d1e5840631.log:   2024-06-19T01:36:57.092Z WARN:   [aaa7a1018b9ad483;86443860fffb28d7] VM File Extractor plugin was unsuccessful.  Max number of vm-file-extractor processes are running. Cancelling the process after 10 minutes as not enough system resources are available. The metadata extraction and indexing of this VM will be handled later by the offline-indexing process.
RecoverVmSessions-b1d958e1-f05b-46a8-af3c-d7d1e5840631.log:   2024-06-19T01:36:57.092Z ERROR:  [aaa7a1018b9ad483;86443860fffb28d7] Unable to repair disk properties which were modified by the VSS Quiesce operation.  VM File Extractor plugin was unsuccessful.  Max number of vm-file-extractor processes are running. Cancelling the process after 10 minutes as not enough system resources are available. The metadata extraction and indexing of this VM will be handled later by the offline-indexing process.
RecoverVmSessions-b1d958e1-f05b-46a8-af3c-d7d1e5840631.log:   2024-06-19T01:36:57.092Z ERROR:  [aaa7a1018b9ad483;86443860fffb28d7] Unable to reset disks to read-write mode after VSS quiesce operation set them to read-only.

Cause

Il processo vm-file-extractor non può essere eseguito a causa della mancanza di memoria sul nodo di ricerca di PowerProtect Data Manager. Il requisito minimo per la memoria libera è 800 MB. L'errore di esecuzione di vm-file-extractor ha causato una configurazione non corretta del bit di sola lettura. In questo modo, si genera l'errore "Unable to reset disks to read/write mode after VSS quiesce operation set them to read-only".

Resolution

1. Accedere a PowerProtect Data Manager Appliance utilizzando SSH, passare all'utente root ed eseguire i comandi riportati di seguito per ottenere la password del nodo di ricerca di PowerProtect Data Manager.

source /opt/emc/vmdirect/unit/vmdirect.env && /opt/emc/vmdirect/bin/infranodemgmt get -secret -node_type SearchNode

2. Accedere a ciascun nodo di ricerca utilizzando le credenziali ottenute nel passaggio 1.
3. Eseguire il comando seguente per controllare l'utilizzo della memoria del nodo di ricerca.

free -m

4. Se la memoria libera è effettivamente inferiore a 800 MB, aggiungere altra memoria al nodo di ricerca o riavviare il nodo di ricerca quando PowerProtect Data Manager è inattivo per liberare la memoria allocata.
5. Eseguire nuovamente il restore della VM.

Affected Products

PowerProtect Data Manager Appliance
Article Properties
Article Number: 000226205
Article Type: Solution
Last Modified: 02 Sept 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.