PowerStore: System Health Checks detects the reboot flag is set
Summary: PowerStore Pre-Upgrade Health Checks (PUHC) off-release detected the reboot flag is set.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The PowerStore Pre-Upgrade Health Check (PUHC) may fail the Checking Node Reboot Needed Flag validation, with the following error: "The reboot_needed flag is incorrectly set on node." with the event error code of 0XE10050020200.
The health check is an off-release PUHC check that is contained in the Health Check thin package. See the Additional Info section for information about the Health Check thin package.
This may be detected when running the PUHC. Example:
The health check is an off-release PUHC check that is contained in the Health Check thin package. See the Additional Info section for information about the Health Check thin package.
This may be detected when running the PUHC. Example:
Cause
The failure message indicates that node's internal flag of reboot_needed is unexpectedly set to true.
The cause of this issue may be result of unusual sequence events that are related to restart following High Availability (HA).
The cause of this issue may be result of unusual sequence events that are related to restart following High Availability (HA).
Resolution
Contact Dell Technical Support or your Authorized Service Representative, and quote this knowledge base article ID.
Additional Information
For more information about off-release Health Checks, see:
KB 000198084 PowerStore: How to use the System Check feature
KB 000192601 PowerStore: How to Check the Health of the Cluster Before Software Upgrade Using Pre-Upgrade Health Check and System Check.
KB 000198084 PowerStore: How to use the System Check feature
KB 000192601 PowerStore: How to Check the Health of the Cluster Before Software Upgrade Using Pre-Upgrade Health Check and System Check.
Affected Products
PowerStoreArticle Properties
Article Number: 000205908
Article Type: Solution
Last Modified: 13 Jun 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.