PowerStore: Health check detects IOPM V2 modules or Ethernet SLICs not properly activated
Summary: A health check identifies any IOPM V2 (I/O Personality Module) modules or Ethernet SLICs (Small Form Factor I/O Card) that may not have been activated correctly. Correct activation is necessary when transitioning from an IOPM V1 module to an IOPM V2 module. It is also essential when replacing or upgrading Ethernet SLICs. ...
Symptoms
PowerStore health checks identify if an IOPM V2 module or an Ethernet SLIC has been detected but not activated. Various services in PowerStore can detect this issue.
For more information about the condition this health check detects see KB 000216965 PowerStore: Incomplete IO module activation results in issues in NVMe expansion enclosure
The issue may be detected and reported as follows:
System Check detection of the issue:
- "
There are front end ports without net devices. (KB#000216558)" - for IOM/SLIC issues identified by System Check - "
SAS ports are found while IO Personality Module V2 is present. (KB#000216558)" - for IOPM issues identified by System Check.
Pre-Upgrade Health Check (PUHC) detection of the issue:
- "
off_release_iom_activation_check (off_release_iom_activation_check)" - "
IO Personality Module or SLIC not activated."
Alert raised by health check in the RxDefinitions package:
- Alert Text: "
IOPM V2 modules or Ethernet SLICs have not been properly activated. KB# 000216558" - Error Code:
0x03700103 - Alert ID:
POWERDOCTOR_ISSUE_MAJOR
Below are examples demonstrating health checks conducted in various scenarios:
-
Running the Pre-Upgrade Health Check (PUHC):
-
Invoking the System Check:
-
Running the System Health Service Script (
svc_health_check) using an SSH connection.[SVC:service@ABCDEF2-A ~]$ svc_health_check run -rhc iom_activation_check Name Location Status Description IOM/IOPM activation check node_a Failed There are front end ports without net devices. (KB#000216558) SUMMARY Status: Failed Passed: 0 Failed: 1 Total: 1
-
Alert raised by RxDefinition:

Cause
The condition can occur in the following cases:
- Activation began before replacement but did not complete.
- Activation was completed, but the wrong module was activated.
As a result of this condition, the following may occur:
- It may not be possible to map volumes to a host.
- It may not be possible to connect NVMe expansion enclosure (ENS24) to IOPM V2.
Resolution
To resolve this issue, contact technical support for assistance. Reference this KB for expedited attention and resolution.
Additional Information
The health checks of this Article are implemented by thin packages that must be manually installed.
- For more information about System Health Checks, see Article 000198084 PowerStore: How to use the System Check feature or Article 000192601 PowerStore: How to Check the Health of the Cluster Before Software Upgrade Using Pre-Upgrade Health Check and System Check.
- For more information about RxDefinitions, see 000193518 PowerStore: Landing for Page RxDefinitions Issues for a complete list of RxDefinitions.