PowerStore: System health check detects a target port group issue that may affect mapping of an NVMeoF volume

Summary: Mapping an NVMeoF volume may lead to service disruption if there had been Add Appliances failures beforehand. The System Health check detects a target port group issue that may result in a service disruption while mapping an NVMeoF volume. ...

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Symptoms

The System Check in the off-release health check package may identify an invalid target group id. This issue is described in KB 000216639 PowerStore: Mapping an NVMeoF volume may lead to service disruption on multi-appliance clusters

The issue is detected in the following scenarios: 
  • Running a System Check using PowerStore Manager (UI) with the Run System Check option:
image.png
 
  • Running the System Health Service Script (svc_health_check) using an SSH connection:  Note: Output truncated for illustrative purposes.
[SVC:cyc@ABCDEF-A ~]$  svc_health_check run -rhc target_port_group_id_check
Name                          Location  Status     Description
Target PortGroup Id Check     node_a    Failed     Max value of LOCAL target_port_group_id is over the max threshold of 29.  (KB000216953)    

Cause

After multiple add appliance failures, the target group id may be assigned a value outside of the valid range. This will impact the cluster when NVMEoF host mapping is being used.

Resolution

Contact technical support for assistance in resolving this issue. This should be resolved ASAP.
If not resolved, there is a high risk of the node may enter service mode or go down affecting the High Availability of the appliance.  

This issue is planned to be resolved in a future PowerStoreOS release. 

Additional Information

Affected Products

PowerStore
Article Properties
Article Number: 000216953
Article Type: Solution
Last Modified: 14 Jun 2025
Version:  4
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