PowerStore: System Health Checks detects an out-of-date System Manager Metadata on Disk (SYMMD) data on disks

Summary: This System Health Check (SHC) to detect if the latest System Manager Metadata on Disk (SYMMD) data is saved on disk. Two copies of SYMMD data are saved on disk. One copy is the same as what is in memory, the current running version. The other copy is from old SYMMD that was saved before NDU. During a disk firmware upgrade, the copy corresponding to the SYMMD in memory can be overwritten with the old copy. This check is to detect the above condition. It reads both copies from the disk, one of them has to be consistent with current running SYMMD. This check fails if both copies are wrong. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

System Health may display a System manager metadata on disk is invalid. (KB#000228110) message in one of the following scenarios:
 

  • Running a System Check using PowerStore Manager (GUI) with the Run System Check option:
KB_000228110_figure1.png
  • Running the System Health Service Script (svc_health_check) using an SSH connection:
Note: Output truncated for illustrative purposes.
[BSC:cyc@8SP3DN3-A ~]$ svc_health_check run -rhc symmd_on_disk_check
Name                               Location  Status     Description
System Manager Metadata on Disk .. node_a    Failed     System manager metadata on disk is invalid. (KB#000228110)
 
 
SUMMARY Status: Failed
   Passed:      0
   Failed:      1
   Total:       1
Note: Results may vary based on the node where the check failed.

The health check is an off-release SHC check that is contained in the Health Check thin package. See the Additional Info section of this article for information about the Health Check thin package.

Cause

Attempting to restart or shut down the System Manager (SYM) node under this condition may cause SYM to not start. This scenario may also trigger a Data Unavailability (DU) condition.

Resolution

To resolve this issue, contact technical support for assistance. Reference KB# 000228110 for expedited attention and resolution.

Additional Information

Affected Products

PowerStore
Article Properties
Article Number: 000228110
Article Type: Solution
Last Modified: 14 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.