VPLEX: Distributed Device Experiencing Performance Issues

Summary: A VPLEX distributed device is experiencing performance issues due to high write latency.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Hosts are experiencing high write latency on VPLEX distributed devices.

 

Cause

For distributed devices, VPLEX confirms that any write I/O is committed to back-end storage on both sites before returning acknowledgement to the host.

If the inter-cluster FC/IP WAN network is experiencing congestion, the round-trip time of I/O packets increases. This increase causes the performance issue.

On the other hand, VPLEX always serves read I/Os from the global cache if the data is available, or from the local back-end array.

VPLEX best practice indicates that the RTT between VPLEX clusters should not exceed 5 ms for optimal performance. For a campus-wide network, the RTT should not exceed 1 ms.

 

Resolution

  1. Check the firmware logs for com/21 and com/24 events that indicate network congestion.

    Example:

    128.221.253.36/cpu0/log:5988:W/"00601661de2210138-2":141384:<4>2017/04/12 09:16:16.10: com/21 COM IO took 1.047 sec to complete (limit 900.000 msec).  Type message, uuid 0x4xxxxxx, transport scsi, msg_len 72
    128.221.252.38/cpu0/log:5988:W/"0060165322f014450-2":2170302:<3>2016/10/22 23:29:35.92: com/24 86 long-latency IOs in past hour (Msg: 86) Printed up to 100.
  2. Confirm that all WAN com ports are up and that the SFP power is greater than 200 uW. If not, follow the KB article: VPLEX: 0x8a45901c, IP Port detects no receive power or 0x8a453013, IP network link down (Dell Support login may be required)

  3. If the VPLEX is an FC metro configuration and the WAN FC switches are Dell-supported, follow the KB article: Connectrix Switches: How to collect Switch Logs (Primary) (Dell Support login may be required). Collect the switch logs and engage Dell support.

  4. If the VPlex is IP metro configuration, validate the IP network health to determine what is causing the congestion.

 

Affected Products

VPLEX Series

Products

VPLEX GeoSynchrony, VPLEX Series, VPLEX VS1, VPLEX VS2, VPLEX VS6
Article Properties
Article Number: 000167575
Article Type: Solution
Last Modified: 09 Jul 2026
Version:  5
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