Dell Unity: CAVA 서버가 오프라인 상태가 되었다가 간헐적으로 복구됨

Summary: CAVA 서버가 오프라인 상태가 되었다가 간헐적으로 복구됨: "바이러스 검사기 서버 xx.xx.xx.xx에 오류가 발생하여 더 이상 작동하지 않습니다. (오류: ERROR_AUTH 64)" :: Category=사용자 구성 요소=DART_VC "바이러스 검사기 서버 xx.xx.xx.xx가 온라인 상태입니다." :: Category=사용자 구성 요소=DART_VC. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

이 문제는 Unity 코드 4.4.0.1536311042 및 Windows Server 2016에서 발생했습니다.

문제 설명:

  1. 고객이 CAVA를 구성했는데, CAVA 서버가 오프라인 상태가 되었다가 몇 초 만에 다시 온라인 상태가 되는 아래 오류가 간헐적으로 발생했습니다.
    다음 오류 로그가 표시됩니다EMCSystemLogFile.log

    "2018-12-28T02:18:22.331Z" "n1988006_spa" "Kittyhawk_safe" "26056" "unix/spa/root" "ERROR" "13:10510021" :: "The virus checker server xx.xx.xx.xx has encountered an error and is no longer operational.(Error: ERROR_AUTH 64)" :: Category=User Component=DART_VC
    "2018-12-28T02:18:41.486Z" "n1988006_spa" "Kittyhawk_safe" "26056" "unix/spa/root" "NOTICE" "13:1051001d" :: "Virus checker server xx.xx.xx.xx is online." :: Category=User Component=DART_VC
    "2018-12-28T02:35:42.361Z" "n1988006_spa" "Kittyhawk_safe" "26056" "unix/spa/root" "ERROR" "13:10510021" :: "The virus checker server xx.xx.xx.xx has encountered an error and is no longer operational.(Error: ERROR_AUTH 64)" :: Category=User Component=DART_VC
    "2018-12-28T02:35:51.678Z" "n1988006_spa" "Kittyhawk_safe" "26056" "unix/spa/root" "NOTICE" "13:1051001d" :: "Virus checker server xx.xx.xx.xx is online." :: Category=User

    다음과 같은 c4_safe_ktrace.log에도 동일한 오류 메시지가 보고되었습니다.

    2018/12/28-21:32:25.865594 115K     7F86FEB3E709     sade:VC: 3:33:[Rick]  The virus checker server 160.46.85.196 has encountered an error and is no longer operational.(Error: ERROR_AUT
    2018/12/28-21:32:25.865596    0     7F86FEB3E709     sade:VC: 3:33:[Rick]  H 64)
    2018/12/28-21:32:25.865617   19     7F8790D83702     sade:SOCK_STREAM: 3:[core]  T_DISCON_REQ: (fd=0x1a0, NS=0) ShutdownStream() request UNSUPPORTED!
    2018/12/28-21:32:25.865622    4     7F8790D83702     sade:SOCK_STREAM: 3:[core]  T_DISCON_REQ: (fd=0x1a0, NS=0)  Handling as DisconnectCloseStream()!
    --
    2018/12/28-21:32:53.272520    0     7FC1D8ADC70A      std:PSMSYS:PSMSYS:psmDataAreaClose(1:13): PENDED...
    2018/12/28-21:32:55.127022 1.8M     7F86FEB3E702     sade:VC: 5:29:[Rick]  Virus checker server 160.46.85.196 is online.
    2018/12/28-21:32:55.128201 1177     7F8790DC7704     sade:SOCK_STREAM: 3:[core]  T_DISCON_REQ: (fd=0x1cb, NS=0) ShutdownStream() request UNSUPPORTED!
    2018/12/28-21:32:55.128206    3     7F8790DC7704     sade:SOCK_STREAM: 3:[core]  T_DISCON_REQ: (fd=0x1cb, NS=0)  Handling as DisconnectCloseStream()!
  2. 오류는 특정 패턴 없이 무작위로 발생했습니다. CAVA 서비스는 영향을 받지 않는 것 같습니다.

  3. KB#462457에 대한 후속 조치를 취했으나 CAVA 서버/Unity/Windows DC 서버 간에 시간차가 나타나지 않았습니다.

  4. 네트워크 추적에 따르면 CAVA 서버가 Ioctl 요청을 보냈지만 Unity FSCTL_VALIDATE_NEGOTIATE_INFO 응답하지 않았고 TCP 연결을 끊었습니다.
    문제가 발생하면 CAVA 서버가 FSCTL_VALIDATE_NEGOTIATE_INFO Ioctl 요청을 보냈지만 Unity가 응답하지 않고 연결을 완료했습니다.

    # 좋은 사례 예

    5817    0.433916    CAVA_IP    CIFS_IP    SMB2    156    Tree Connect Request Tree: \\rick\CHECK$
    5820    0.433983    CIFS_IP     CAVA_IP    SMB2    138    Tree Connect Response
    5823    0.434164    CAVA_IP    CIFS_IP    SMB2    212    Ioctl Request FSCTL_VALIDATE_NEGOTIATE_INFO
    5826    0.434217    CIFS_IP     CAVA_IP    SMB2    194    Ioctl Response FSCTL_VALIDATE_NEGOTIATE_INFO  <=========== good case

    # 나쁜 케이스 예

    1806    0.096779    CAVA_IP    CIFS_IP    SMB2    156    Tree Connect Request Tree: \\rick\CHECK$
    1807    0.096854    CIFS_IP     CAVA_IP    SMB2    138    Tree Connect Response
    1818    0.097124    CAVA_IP    CIFS_IP    SMB2    212    Ioctl Request FSCTL_VALIDATE_NEGOTIATE_INFO
    1820    0.097200    CIFS_IP     CAVA_IP    TCP    54    445   52006 [FIN, ACK] Seq=85 Ack=261 Win=304 Len=0   <=========== bad case
  5. 이 문제는 emcopy를 사용하여 VNX에서 Unity로 데이터를 마이그레이션하는 것과 같이 CIFS 데이터 복사에 영향을 줄 수 있습니다.
    여러 복사본을 동시에 실행하며, 매번 오류와 함께 간헐적으로 다른 복사본이 실패합니다.

    Client OS : Microsoft (build 9200)
    TH000 : 02:28:08 : ERROR (53) : unable get server info from \\cifsserver.exmaple.net

 

Cause

Unity가 바인딩된 연결이 아닌 초기 연결을 사용하여 정보를 검증해야 하기 때문에 문제가 됩니다. 이로 인해 고객 문제가 발생할 수 있습니다.

 

Resolution

이것은 SMB 버전 3.0.2에서만 문제이며 3.1 또는 2.1로 전환해도 작동합니다. 그리고 3.0.2에서도 해결 방법이 있습니다.

해결 방법: Windows 서버 또는 CAVA 서버의 Dislabe Multichannel

관리자 권한으로 PowerShell을 실행한 후 다음을 수행합니다.

PS C:\windows\system32> Get-SmbClientConfiguration


ConnectionCountPerRssNetworkInterface : 4
DirectoryCacheEntriesMax              : 16
DirectoryCacheEntrySizeMax            : 65536
DirectoryCacheLifetime                : 10
DormantFileLimit                      : 1023
EnableBandwidthThrottling             : True
EnableByteRangeLockingOnReadOnlyFiles : True
EnableInsecureGuestLogons             : False
EnableLargeMtu                        : True
EnableLoadBalanceScaleOut             : True
EnableMultiChannel                    : True
EnableSecuritySignature               : True
ExtendedSessionTimeout                : 1000
FileInfoCacheEntriesMax               : 64
FileInfoCacheLifetime                 : 10
FileNotFoundCacheEntriesMax           : 128
FileNotFoundCacheLifetime             : 5
KeepConn                              : 600
MaxCmds                               : 50
MaximumConnectionCountPerServer       : 32
OplocksDisabled                       : False
RequireSecuritySignature              : False
SessionTimeout                        : 60
UseOpportunisticLocking               : True
WindowSizeThreshold                   : 8

PS C:\windows\system32> Set-SmbClientConfiguration -EnableMultiChannel $false

Confirm
Are you sure you want to perform this action?
Performing operation 'Modify' on Target 'SMB Client Configuration'.
[Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help (default is "Y"): yes
PS C:\windows\system32> Get-SmbClientConfiguration


ConnectionCountPerRssNetworkInterface : 4
DirectoryCacheEntriesMax              : 16
DirectoryCacheEntrySizeMax            : 65536
DirectoryCacheLifetime                : 10
DormantFileLimit                      : 1023
EnableBandwidthThrottling             : True
EnableByteRangeLockingOnReadOnlyFiles : True
EnableInsecureGuestLogons             : False
EnableLargeMtu                        : True
EnableLoadBalanceScaleOut             : True
EnableMultiChannel                    : False
EnableSecuritySignature               : True
ExtendedSessionTimeout                : 1000
FileInfoCacheEntriesMax               : 64
FileInfoCacheLifetime                 : 10
FileNotFoundCacheEntriesMax           : 128
FileNotFoundCacheLifetime             : 5
KeepConn                              : 600
MaxCmds                               : 50
MaximumConnectionCountPerServer       : 32
OplocksDisabled                       : False
RequireSecuritySignature              : False
SessionTimeout                        : 60
UseOpportunisticLocking               : True
WindowSizeThreshold                   : 8

 

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid
Article Properties
Article Number: 000050509
Article Type: Solution
Last Modified: 07 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.