Le SDS ne parvient pas à quitter le mode maintenance après sa mise à niveau pendant la mise à niveau sans perturbation de PowerFlex

Summary: Lors de la mise à niveau sans perturbation, le système dispose d’un SDS bloqué en mode maintenance et l’opération de mise à niveau d’Installation Manager échoue.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Les journaux d’événements MDM affichent le SDS en cours de mise à niveau, suivi d’une commande de sortie du mode maintenance :

2023-07-15 03:12:47.469000:0012714:SDS_UPGRADED                     INFO     SDS: <sds_name> (ID  <sds_id> ) upgraded to version 3.6.x
2023-07-15 03:12:47.505000:0012715:SDS_RECONNECTED                  INFO     SDS: <sds_name> (ID  <sds_id>) reconnected. 
 
2023-07-15 03:13:21.618000:0012930:MDM_CLI_CONF_COMMAND_RECEIVED    INFO     Command exit_maintenance_mode received, User: ': <user>'. [50667] SDS: ID: <sds_id>;

 

Le SDS tente de quitter le mode maintenance, mais échoue.

Les journaux de suivi SDS peuvent afficher les éléments suivants :

2023/07/15 03:12:57.322606 7feaa54e0db0:contCmd_AddCombAndSetState:10712: Set comb state (reconstruct) failed 13598001806a new state SECONDARY, rc NOT_FOUND
2023/07/15 03:12:57.322806 7feaa54e0db0:contCmd_AddCombAndSetState:10712: Set comb state (reconstruct) failed 13598001808c new state SECONDARY, rc NOT_FOUND
...
 
2023/07/15 03:12:58.030449 7feaa57ffdb0:contDev_FlushDeviceDirtyDrl_Async:09708: Device 0xdfef6e6c001d0005 drl flush skipped due to device in error
2023/07/15 03:12:58.030459 7feaa5568db0:contDev_FlushDeviceDirtyDrl_Async:09708: Device 0xdfef6e70001d0009 drl flush skipped due to device in error
...
 
2023/07/15 03:13:21.650684 7fea9dc59db0:ioh_ResetCombDrl:05345: Reset Drl - No comb:13598001800b device: 0xdfef6e6c001d0005
2023/07/15 03:13:21.650911 7fea9dc15db0:ioh_ResetCombDrl:05345: Reset Drl - No comb:135980018079 device: 0xdfef6e70001d0009
...

 

La sortie ci-dessus montre qu’après la mise à niveau, les périphériques ont dû être reconstruits avec le nouveau format de métadonnées, ce qui se produit lors de la mise à niveau de 3.0.x vers 3.5.x ou version ultérieure.

La fonction contDev_FlushDeviceDirtyDrl_Async considère ces appareils comme des erreurs, puis les appareils commencent à signaler qu’il n’y a pas de peignes.

Les journaux de suivi SDS diffusent la ligne « Reset DRL - No comb » jusqu’à ce que le problème soit résolu.

 

Cause

Au cours de l’opération de reconstruction des métadonnées de l’appareil pour la mise à niveau sans perturbation, une condition de concurrence peut se produire dans le code MDM qui empêche l’exécution complète de l’opération, et les appareils passent dans un état où ils pensent ne posséder aucune des données.

 

Le redémarrage du service SDS force le SDS à se reconnecter au MDM, lequel éduque le SDS sur les combs qu’il possède.

 

Resolution

Solution

Pour résoudre le problème, redémarrez le service SDS sur le SDS qui ne parvient pas à quitter le mode maintenance. Pour redémarrer le service SDS, exécutez une commande pkill sds Commande.
Attendez que le SDS quitte le mode maintenance, puis relancez l’opération de mise à niveau d’Installation Manager.

 

Versions affectées

PowerFlex 3.x

 

Problème résolu dans la version

PowerFlex 3.6.3
PowerFlex 4.5.2

 

Additional Information

Versions affectées

PowerFlex 3.x

Problème résolu dans la version

PowerFlex 3.6.3

PowerFlex 4.5.2

Article Properties
Article Number: 000217116
Article Type: Solution
Last Modified: 28 Feb 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.