Isilon: Dvojice partnerských uzlů DE gen6 (H400, A200, A2000) generuje události a zprávy konzole, které indikují problémy s připojením NTB po výměně nebo přesunutí výpočetního modulu
Summary: Pár partnerských uzlů Gen6 DE (H400, A200, A2000) může někdy začít generovat chybové zprávy oznamující problémy s jejich připojením NTB. Chyby mohou zahrnovat opakované zprávy "NTB link up/down" a chyby vyjednávání rychlosti připojení. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Pár partnerských uzlů Gen6 DE (H400, A200, A2000) může někdy začít generovat chybové zprávy oznamující problémy s jejich připojením NTB. Může se jednat o opakované zprávy "link up/down" a také chyby při vyjednávání rychlosti připojení, například:
mnv0: HW link down event mnv0: HW link up event mnv0: Failed to negotiate PCIe lane speed; expected 3 lane speed, got 2. mnv0: transport link up mnv0: peer up
Případně protokoly nebo konzole mohou jednoduše zobrazit spojení NTB jako nefunkčně a nezpřístupňují se. V současné době existuje několik možných příčin tohoto problému, z nichž některé jsou stále předmětem šetření. Pokud byl jeden nebo oba dotčené uzly nedávno přesunuty do jiného slotu na šasi nebo byly vyměněny jejich výpočetní moduly, problém a řešení zdokumentované v tomto článku znalostí se mohou vyskytnout. Tento problém se netýká uzlů EP (F800, H600, H500).
Cause
Partnerské uzly spolu navzájem komunikují prostřednictvím speciálního komunikačního kanálu s názvem NonTransparent Bridge (NTB) zabudovaného v backplane šasi. Za normálního provozu musí mít oba uzly v partnerském páru jinou hodnotu PPD, aby mohly navzájem komunikovat prostřednictvím NTB. Hodnoty PPD se přiřazují na základě ID slotu uzlu v šasi. Tento problém je způsoben systémem BIOS uzlu, který si ponechává staré ID slotu uzlu, když je uzel nebo výpočetní modul vyměněn do jiného slotu, než z něj byl původně dodán, namísto zjištění ID nového slotu. To může způsobit nesprávné nastavení hodnoty PPD, což způsobuje konflikt, který zabraňuje uzlům navázat spojení NTB.
Resolution
Spusťte následující příkaz na obou uzlech v dotčené partnerské dvojici a ověřte, zda je problém zdokumentovaný v tomto článku znalostí platný:
# sysctl dev.ntb_hw.0.debug_info.ppd
Každý uzel bude reagovat pomocí příkazu:
dev.ntb_hw.0.debug_info.ppd:
73,
Nebo:
dev.ntb_hw.0.debug_info.ppd: 93,
– Pokud jeden uzel v páru odpoví 73 a druhý odpoví 93, tyto uzly nejsou aktuálně dotčeny problémem zdokumentovaným v tomto článku znalostí.
Další pomoc vám poskytne technická podpora isilon společnosti EMC.
– Pokud oba uzly zareagují stejným číslem, 73 nebo 93, jsou dotčeny problémem zdokumentovaným v tomto článku znalostí. Tento problém je vyřešen v aktualizovaném firmwaru uzlu, který je součástí balíčku firmwaru uzlu 10.1.6 a novějších, a také v opravě kódu zahrnuté v systému OneFS 8.1.0.4 a novějším. Každá aktualizace sice problém řeší samostatně, obě verze však obsahují další důležité opravy, proto se doporučuje nainstalovat obě verze.
# sysctl dev.ntb_hw.0.debug_info.ppd
Každý uzel bude reagovat pomocí příkazu:
dev.ntb_hw.0.debug_info.ppd:
73,
Nebo:
dev.ntb_hw.0.debug_info.ppd: 93,
– Pokud jeden uzel v páru odpoví 73 a druhý odpoví 93, tyto uzly nejsou aktuálně dotčeny problémem zdokumentovaným v tomto článku znalostí.
Další pomoc vám poskytne technická podpora isilon společnosti EMC.
– Pokud oba uzly zareagují stejným číslem, 73 nebo 93, jsou dotčeny problémem zdokumentovaným v tomto článku znalostí. Tento problém je vyřešen v aktualizovaném firmwaru uzlu, který je součástí balíčku firmwaru uzlu 10.1.6 a novějších, a také v opravě kódu zahrnuté v systému OneFS 8.1.0.4 a novějším. Každá aktualizace sice problém řeší samostatně, obě verze však obsahují další důležité opravy, proto se doporučuje nainstalovat obě verze.
Affected Products
Isilon, Isilon Gen6Article Properties
Article Number: 000056963
Article Type: Solution
Last Modified: 28 Jun 2023
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.