NVP vProxy: SQL Server 2022 App Consistent Backups Not Starting

Summary: A Windows SQL Virtual Machine (VM) is configured for app consistent backups using the NetWorker VMware Protection (NVP) MSVMAPPAGENT. The backup does not start and no messages are seen in the logs. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • The NetWorker VMware Protection (NVP) solution is configured to protect a Windows Server 2022 Virtual Machine (VM).
  • The VM contains SQL Server 2022.
  • The workflow configured to protect the VM has "App Consistency" enabled, which is intended to perform an MSVMAPPAGENT (SQL consistent) backup of the VM.
  • After the backup workflow starts, no backup session is established for the SQL VM. No VM snapshot is created in VMware.
  • There are no errors in the VM backup session log or the "C:\Program Files\DPSAPPS\MSVMAPPAGENT\logs" on the VM. The MSVMAPPAGENT folder may not even be created on the VM.
  • Standard image backups (not app consistent) succeed for the same VM.

Cause

The vProxy solution does not support App Consistent backups for SQL Server 2022. See note 58266 in the NetWorker Compatibility matrix: E-Lab Interoperability Navigator 2.0-HOME (Requires Dell support account sign-in)

Resolution

NOTE: Review the NetWorker Compatibility Matrix for any changes to supporting Windows and SQL Server 2022.

To perform SQL backups on the VM, install the NetWorker client and NetWorker Module for Microsoft software.

The NetWorker client installation packages and documentation can be obtained through the NetWorker products page: 
Support for NetWorker | Overview

The NetWorker Module for Microsoft installation packages and documentation can be obtained through: 
Support for NetWorker Module for Microsoft | Overview

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000291158
Article Type: Solution
Last Modified: 09 Feb 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.