NetWorker: NMC workflow details error "unable to obtain root job list"

Summary: The NetWorker Management Console (NMC) workflow "Show Details" option generates an error message: "unable to obtain root job list."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Clicking Show Details on any workflow in NMC results in this error message:
Error unable to accept message bus block   

 

Cause

The root cause of the issue could be attributed to missing exchanges or corruption in RabbitMQ's data structures. 

Resolution

  1. On the NetWorker server, open an Admin PowerShell prompt or root shell. Run the following commands to stop the NetWorker and NMC services:

Linux: nsr_shutdown ; sleep 10 ; systemctl stop gst
Windows: net stop nsrexecd /y
 

  1. Rename the RabbitMQ tmp folder:

Linux: /nsr/tmp/rabbitmq
Windows: C:\Program Files\EMC NetWorker\nsr\tmp\RabbitMQ 
 

  1. Start the NetWorker server and NMC services. When RabbitMQ was renamed, the service startup created new files, including a new data directory:

Linux: systemctl start networker ; sleep 10 ; systemctl start gst
Windows (PowerShell): net start nsrd ; Start-Sleep 10 ; net start gstd

Article Properties
Article Number: 000332286
Article Type: Solution
Last Modified: 15 Dec 2025
Version:  1
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