AppSync: Failing to mount XIO volume with error - "obj_identifier_not_unique"

Summary: The mount fails because the LUN cannot be mapped on the array due to an XIO error condition.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Mounting a copy that resides on XtremIO storage fails with the following errors.

Service plan events:
Mounting file systems on mount host <Mount host name>.
Error occured while masking the target snapshots to the mount host. Check the connectivity status of all backend arrays.
Mount copy phase for <Service plan name> completed with errors

 
Server log:
10-01-2019 07:31:28.519 ERROR [EJB default - 5] [com.emc.archway.commands.genericstorage.MountMixedArraySnapshotCommandBean] [<AS Server Name>] [] 338616ba-15cc-4f61-8505-8047a3d8ff79->>> Mount failed with Error com.emc.archway.errorMessages.XIORESTException: REST operation failed for XMS <XMS IP> for REST operation: POST /api/json/v2/types/lun-maps.

XMS Audit Log:
2019-10-01 07:31:27,266: [2128:afe7] User: admin, Command: map_lun, Arguments: {vol_obj_id=["", "<snap name>", "0"], lun=None, tg_obj_id=["", "", "1"], ig_obj_id=["", "<snip>", "0"], sys_id=["", "<snip>", "0"]}
2019-10-01 07:31:27,496: [2128:9f8d] User: admin, Command: map_lun, Failed: obj_identifier_not_unique

Cause

The issue is caused by an error condition on the XtremIO Management Server which is described in KB article 533777.

Resolution

Assistance from XtremIO Technical Support is required to resolve this issue. 

Open a service request with Dell EMC under the XtremIO product, and refer to this article ID and article 533777.

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000168362
Article Type: Solution
Last Modified: 19 Sept 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.