ECS: Kodeoppgradering PFE for All-Flash Array (AFA) 3. generasjons EXF900-plattform – ET-5187

Summary: Denne kunnskapsbaseartikkelen (KB) dokumenterer Proactive Field Event (PFE) ET-5187 for ECS Gen3 EXF900-kodeoppgraderinger. PFE er den nye betegnelsen for Field Change Order (FCO) programmer. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

3. generasjons EXF900 All-Flash-arraysystemer kan oppleve:

  • Ytelsesproblemer påvirket lese- og skriveoperasjoner. 
  • ECS-ustabilitet på grunn av uklare katalogtabeller (DT-er), som kan føre til utilgjengelighet av data (DU). 

Cause

  • For ytelsesproblemer: Se produktmerknadene for ECS 3.8.1.4 for å få en liste over løste problemer som kan påvirke ECS-ytelsen. 
  • For ikke-klare DT-er kan dette være forårsaket av en kappløpssituasjon mellom ECS-tjenestene, noe som kan føre til inkonsekvent metadatadumping mellom tjenestene.

Resolution

  • Ledelsen innen ECS-teknikk, kvalitet og tjenester ber om en proaktiv felthendelse (PFE) for alle All-Flash Array Gen3 EXF900-systemer. 
  • PFE skal oppgraderes til den nyeste anbefalte koden ECS 3.8.1.5 General Availability (GA), som inneholder en løsning på problemene som er beskrevet i denne KB-artikkelen. 
    • Hvis du vil ha mer informasjon om ECS-mål og anbefalt kode, kan du se kunnskapsartikler 216334 og 205512.
  • Dell Technologies vil åpne forespørsler om oppgraderingstjeneste som en del av PFE. 
  • Når oppgraderingen er fullført, starter Dell Services en skanning for å oppdage potensielle inkonsekvenser i metadatadumpen som kan ha oppstått når ECS kjørte tidligere kodenivåer.
    • Hvis du er tilkoblet ved hjelp av gateway for sikker tilkobling (SCG) eller har aktivert hjemmeoppringing via en dedikert SMTP-server (Simple Mail Transfer Protocol), opprettes en serviceforespørsel hvis skanneren finner berørte metadata eller støter på et kjøretidsproblem. Ingen overvåking er nødvendig. 
    • Hvis ECS-boksen ikke ringer hjem, må du overvåke skanneresultatene. Se delen Tilleggsinformasjon i denne KB-artikkelen for instruksjonene. 

Additional Information

Kontroller skanneresultatene etter oppgradering til ECS 3.8.1.4 eller nyere versjoner.

  1. Koble til en ECS-vert ved hjelp av SSH:
# ssh ecs.host.com
  1. Koble til hovednoden:
# ssh master
  1. Kjør sjekken:
# sudo python /usr/local/xdoctor/tools/scanners/btree_invalid_page_scan.py status 

Eksempel:

admin@murray-EX500:~> ssh master
Last login: Thu Aug 26 20:42:02 2021 from 10.184.65.213

admin@murray-EX500:~> sudo python /usr/local/xdoctor/tools/scanners/btree_invalid_page_scan.py status
btree_invalid_page_scan.py v1.2.0 (svc_tools v2.21.0)                 Started 2025-01-16 18:50:05

Start                Resume   Last Update                    Complete  ETA
Node    JobID                                          Time                 Time     Time                 Progress  DT        Hours   Status    SubStatus  Conclusion
----------------------------------------------------------------------------------------------------------------------------------------------------------------------
r01n01  DTABtreeInvalidPageScanner-3-1737053178-50097  2025-01-16 18:46:18  Unknown  2025-01-16 18:46:58  100.00 %  128/128   0.00    Complete             NotImpacted

 

Hvis skanningen rapporterer at VDC er berørt:

  • Det kreves en serviceforespørsel for å undersøke den.
    • Kunder med tilkoblede områder kontrollerer at en serviceforespørsel er opprettet. 
    • Dark Site-kunder, kontakt Dells kundestøtte for å åpne en serviceforespørsel.
  • Det er mulig at et støt identifiseres før skannestatusen er fullført. Kontakt Dells kundestøtte hvis du ser Påvirket.
 

Ingen ekstra handling er nødvendig hvis skanningen rapporterer at den virtuelle disken ikke påvirkes NotImpacted.

Affected Products

ECS, ECS Appliance, ECS Appliance Hardware Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption
Article Properties
Article Number: 000252800
Article Type: Solution
Last Modified: 02 Dec 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.