Avamar: The hard limit (quota) may not be enforced for backups which complete quickly
Summary: The Avamar hard limit (quota) may not be enforced for backups which complete quickly.
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Symptoms
Some client backups complete successfully even after exceeding the Hard Limit (quota) set.
Ideally, a client backup setup with a "hard limit" will cancel and fail the backup activity with Hard limit exceeded, and set the hard_limit_exceeded column in the Activity Report to True.
session_id | cid | hard_limit_exceeded
9138687480008009 | 7a233df16d6a9f50e612ffaccbe5e9c9fd761bbb | t
9138696120009409 | 7a233df16d6a9f50e612ffaccbe5e9c9fd761bbb | f
9138704760006009 | 7a233df16d6a9f50e612ffaccbe5e9c9fd761bbb | f
9138713400008409 | 7a233df16d6a9f50e612ffaccbe5e9c9fd761bbb | f
9138722040008509 | 7a233df16d6a9f50e612ffaccbe5e9c9fd761bbb | f
9138686689884609 | 7a233df16d6a9f50e612ffaccbe5e9c9fd761bbb | t
Cause
The client backup finished within 30 seconds.
Resolution
The way that the "hard limit" feature works is as follows:
1. The client sends session progress information to the
GSAN persistent store every 30 seconds. The total bytes scanned are included in the session progress data.
2. The Management Console Server (MCS) polls the
GSAN persistent store (using the "avmaint getclientmsgs" command) approximately once every 30 seconds.
3. From the output of the "
avmaint getclientmsgs" command, the MCS determines if the "total bytes scanned" has exceeded the hard backup dataset limit threshold.
4. If the total bytes scanned are greater than the hard backup dataset limit threshold, then the MCS generates a cancellation work order and marks the backup as "
hard_limit_exceeded".
5. Even if the backup completes before the MCS can check the limit and cancel the backup, the MCS still marks the backup as "
hard_limit_exceeded".
Note: If a backup with a hard limit set completes within 30 seconds, it will complete successfully as the first polling happens after 30 seconds. However, it is still marked in the database (or the Activity Report tab in Admin UI) for "hard_limit_exceeded" as "true":

Additional Information
See the following article: Avamar: How to identify which Avamar clients have breached the backup soft and hard limits
Affected Products
AvamarProducts
AvamarArticle Properties
Article Number: 000039291
Article Type: Solution
Last Modified: 06 Oct 2025
Version: 9
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