Avamar: O backup está lento ou falha com o erro "Time out - end" devido a muitos dados novos ou alterados
Summary: Um backup do Avamar está lento ou falha com "Timeout - end" devido a muitos dados novos ou alterados.
Symptoms
Um backup do Avamar parece ser executado mais lentamente do que o normal ou não é capaz de concluir dentro de sua janela de backup regular.
O log do client mostra que o backup contém uma alta porcentagem de arquivos modificados e/ou muitos dados novos.
Extração de log mostrando muitos arquivos alterados.
2013-12-03 20:48:24 avtar Info <5156>: Backup #72 timestamp 2013-12-03 20:48:24, 2,890,814 files, 420,421 folders, 5,362 GB (2,743,151 files, 24.36 GB, 0.45% new)
Esse log mostra que o backup examinou 2.890.814 arquivos e que 2.743.151 desses arquivos foram modificados desde o último backup. Apesar dessa grande porcentagem de arquivos ser modificada, apenas 0,45% dos novos dados foram enviados ao Avamar Server.
Extração de log mostrando muitos dados adicionais.
2015-09-26 11:09:52 avtar Info <5157>: PARTIAL Backup #31 timestamp 2015-09-26 11:20:21, 4,591 files, 1,044 directories, 145.1 GB (2,082 files, 61.63 GB, 42.47% new)
Essa extração de log mostra que 60 GB de novos dados foram adicionados ao backup, em comparação com um tamanho total de backup de 145 GB.
Cause
O motivo pelo qual o backup leva mais tempo nessas situações é porque o avtar deve examinar cada arquivo no conjunto de dados para verificar se ele foi modificado.
Os arquivos modificados são divididos em pequenos fragmentos, atribuídos a um hash SHA e, em seguida, comparados com o conteúdo do cache. Os arquivos que não estão no cache são verificados com os mantidos no servidor Avamar e, se estiverem ausentes, são enviados pela rede. Isso pode levar muito tempo para arquivos grandes.
O Avamar está se comportando conforme esperado, mas os dados podem ser incomuns ou algum outro processo pode estar em operação no conjunto de dados para modificar os arquivos.
Se muitos dados novos tiverem sido adicionados a um backup do Avamar, o trabalho levará mais tempo para processar e ingerir os novos arquivos.
Resolution
O cliente deve analisar o cliente e determinar se a alteração de dados é intencional e devido a uma atividade normal.
O cliente modificou o conjunto de dados do client ou adicionou uma unidade de disco?
Se o volume de novos dados ou o número de arquivos aumentar, mesmo depois que o backup inicial for concluído, ele poderá eventualmente não ser mais concluído dentro dos limites de uma janela diária.
Analise o log de backup e compare-o com um log de backup anterior em que o backup foi concluído dentro do período de tempo regular.
Se o volume de dados de backup tiver aumentado além do escopo do projeto original, procure assistência do Dell Professional Services ou do Centro de projeto de backup e recuperação da Dell.
Additional Information
O seguinte artigo da DELL é útil para investigar quais arquivos de um backup sofreram modificações e precisaram ser processados pelo Avamar.
O Avamar não modifica arquivos nem usa o "bit de arquivamento".
Investigue o que está causando a modificação dos arquivos ou dos metadados dos arquivos.
Alguns programas de software antivírus foram observados para modificar os atributos de metadados de um arquivo, seja por projeto ou acidente.
Exemplos deste comportamento foram observados com os seguintes produtos.
- Sophos:
- Baixo desempenho de backup para o Avamar Client que executa o antivírus Sophos
- 118630: Sophos Anti-Virus fazendo com que os tempos de backup aumentem.
- Trend Micro:
- Consulte Hotfix 1383 nestas notas da versão.