Avamar: Slow backup of Avamar client running Sophos anti-virus
Summary: This article discusses situations where an Avamar client running Sophos anti-virus experiences poor backup performance.
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Symptoms
This behavior can cause long running Avamar backups and may prevent backups from finishing within the available backup window.
An Avamar client where Sophos anti-virus is installed may occasionally experience poor backup performance when a Sophos on-demand scan is run on the system.
On days where Sophos anti-virus runs an on-demand scan, Avamar may report the proportion of changed files to be high.
On other days, the proportion of changed files is more typical.
An Avamar client where Sophos anti-virus is installed may occasionally experience poor backup performance when a Sophos on-demand scan is run on the system.
On days where Sophos anti-virus runs an on-demand scan, Avamar may report the proportion of changed files to be high.
avtar Info <5156>: Backup #82 timestamp 2014-03-21 16:24:53, 80,687 files, 11,757 folders, 46.06 GB (80,188 files, 17.03 GB, 36.98% new) avtar Info <6083>: Backed-up 46.06 GB in 73.38 minutes: 38 GB/hour (65,976 files/hour)Here, avtar is reporting that the changed data (the values in brackets) are very high relative to the dataset being backed up. In this case, over 99% of the files are detected to have changed (80,188 files out of 80,687)
On other days, the proportion of changed files is more typical.
avtar Info <5156>: Backup #91 timestamp 2014-04-03 10:11:54, 139,164 files, 13,805 folders, 60.73 GB (4 files, 280.1 KB, 0.00% new) avtar Info <6083>: Backed-up 60.73 GB in 7.03 minutes: 519 GB/hour (1,188,522 files/hour)
Cause
The Avamar client process (avtar) relies on the ctime of a file to determine if that file was changed. If third-party software alters the ctime of a file in the dataset, avtar will detect that file to have changed. Avtar must then process (chunk, compress, hash) the entire file.
This can take considerable time if many files have had their ctime modified or where individual files are large.
As discussed in the Sophos documentation
7.4 Archiver backs up all files that have been scanned on demand.
This is because of changes that Sophos Anti-Virus makes in the status-changed time of files. By default, Sophos Anti-Virus tries to reset the access time (atime) of files to the time shown before scanning.
However, this changes the inode status-changed time (ctime). If your archiver uses the ctime to decide whether a file has changed, it backs up all files scanned by Sophos Anti-Virus.
Resolve the problem:
Run sweep with the option --no-reset-atime.
This can take considerable time if many files have had their ctime modified or where individual files are large.
As discussed in the Sophos documentation
7.4 Archiver backs up all files that have been scanned on demand.
This is because of changes that Sophos Anti-Virus makes in the status-changed time of files. By default, Sophos Anti-Virus tries to reset the access time (atime) of files to the time shown before scanning.
However, this changes the inode status-changed time (ctime). If your archiver uses the ctime to decide whether a file has changed, it backs up all files scanned by Sophos Anti-Virus.
Resolve the problem:
Run sweep with the option --no-reset-atime.
Resolution
Follow the Sophos documentation and configure Sophos to run with the option --no-reset-atime.
Affected Products
AvamarProducts
Avamar, Avamar ClientArticle Properties
Article Number: 000041039
Article Type: Solution
Last Modified: 06 Feb 2025
Version: 5
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