Avamar en ondersteuning voor CIFS (SMB) en NFS toegewezen netwerkshares

Summary: In dit artikel wordt uitgelegd dat een gewone Avamar-client geen officiële ondersteuning biedt voor het maken van back-ups van data van CIFS (SMB) en NFS-toegewezen netwerkshares. Alleen NDMP-versnellerknooppunten ondersteunen deze functionaliteit. Er is een tijdelijke oplossing voor speciale situaties, maar de ondersteuning is beperkt. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Hoewel een gewone Avamar-client een back-up kan maken van data van toegewezen CIFS-schijven en geëxporteerde NFS-mounts, wordt deze functionaliteit niet officieel ondersteund.

Dell Support helpt niet bij het configureren of oplossen van problemen met betrekking tot de back-up of het herstel van dergelijke data.

Veelvoorkomende problemen met betrekking tot het maken van een back-up van CIFS-, NFS- en SMB-shares omvatten, maar zijn niet beperkt tot het volgende: -
  • Als er een back-up van Windows-gegevens wordt gemaakt met behulp van een UNIX Avamar-client, gaan de Windows Access Control Lists (ACL's) verloren. Omgekeerd geldt dat als er een back-up van UNIX-gegevens wordt gemaakt met behulp van een Windows-client, de UNIX-ACL's verloren gaan.
  • Back-upprestaties kunnen slecht zijn.
  • Klanten kunnen problemen ondervinden met derden,
  • Klanten kunnen problemen ondervinden die worden veroorzaakt door interoperabiliteit van CIFS-versies.
  • Er is geen faciliteit om VSS-achtige snapshots uit te voeren van data die zich op een toegewezen CIFS- of NFS-share bevinden. Van geopende bestanden wordt mogelijk niet consistent een back-up gemaakt.



Cause

De functionaliteit wordt niet officieel ondersteund.

Uittreksel uit de gebruikershandleiding voor back-upclients:
Probeer geen back-up te maken van een CIFS/NFS-netwerkshare door een Avamar-client op een lokale computer te installeren. Een poging om dit te doen resulteert in een ernstige verslechtering van de back-up- en herstelprestaties en er wordt geen back-up gemaakt van metagegevens zoals mappen, ACL's en bestandsmachtigingen. Als u een back-up wilt maken van een CIFS/NFS-share, installeert u een Avamar-client op de sharecomputer of gebruikt u NDMP om een back-up van de data te maken."

Resolution

Van storageapparaten zoals NAS-bestanden moet een back-up worden gemaakt met behulp van een Avamar Network Data Management Protocol (NDMP)-versneller.

Het Avamar NDMP-versnellerknooppunt is een speciale Avamar-client. Het voert de reguliere Avamar Linux-clientsoftware en de Avamar NDMP-plug-in uit om back-ups te maken van data van ondersteunde filers met behulp van het NDMP-protocol. 
Informatie over de functionaliteit van NDMP-versnellers is beschikbaar in de Avamar NDMP-versnellergids of u kunt contact opnemen met de EMC Account Manager.

Als het systeem dat de data exporteert met behulp van CIFS of NFS een besturingssysteem heeft dat door Avamar wordt ondersteund, installeert u er een client op en verzamelt u bestanden rechtstreeks.
Indien mogelijk moet er rechtstreeks een back-up worden gemaakt van de server waarop de CIFS-, NFS- of SMB-shares worden gehost met een client die op het bestandssysteem is geïnstalleerd.

Tijdelijke oplossing:

Stap één:
De klant moet akkoord gaan en reageren met een e-mail waarin hij begrijpt dat de ondersteuning beperkt is en dat hij akkoord gaat met de volgende voorwaarden.

De klant heeft de onderstaande beperkingen gelezen en begrijpt deze volledig.

Veelvoorkomende problemen met betrekking tot het maken van een back-up van CIFS-, NFS- en SMB-shares omvatten, maar zijn niet beperkt tot het volgende: -
  • Als er een back-up van Windows-gegevens wordt gemaakt met behulp van een UNIX Avamar-client, gaan de Windows Access Control Lists (ACL's) verloren. Omgekeerd geldt dat als er een back-up van UNIX-gegevens wordt gemaakt met behulp van een Windows-client, de UNIX-ACL's verloren gaan.
  • Back-upprestaties kunnen slecht zijn.
  • Klanten kunnen problemen ondervinden met derden,
  • Klanten kunnen problemen ondervinden die worden veroorzaakt door interoperabiliteit van CIFS-versies.
  • Er is geen faciliteit om VSS-achtige snapshots uit te voeren van data die zich op een toegewezen CIFS- of NFS-share bevinden. Van geopende bestanden wordt mogelijk niet consistent een back-up gemaakt.
  • Ondersteuning is beperkt en wordt gegeven als een beste inspanning.
Controleer of de e-mail wordt weergegeven voor de case voordat u verdergaat.

Stap twee:
De klant moet een account selecteren of maken met volledige administratorbevoegdheden (domeinbeheerder) op de bron van de share.

Stap drie:
Op de client die wordt gebruikt om de back-up uit te voeren, stelt u de service "Backup Agent" in om u aan te melden als het account in stap twee.

Stap vier:
Definieer voor back-up een specifieke dataset en specificeer het pad van de share met behulp van de UNC-indeling. 
Op het tabblad "Source Data" van de plug-inopties:
NIET alle lokale Windows-bestandssystemen opnemen of Alle lokale Windows-bestandssystemen selecteren. Alle lokale Windows-bestandssystemen zijn standaard geselecteerd. Hiermee wordt een back-up gemaakt van alle data in het bestandssysteem.
De klant moet de dataset beperken tot specifieke items en de volgende stappen uitvoeren:
a. Typ in het pad van bestand of map het pad als voorbeeld: \\server\share\map
b. Klik op TOEVOEGEN.

Voor Herstellen moet de doelmap als voorbeeld worden opgegeven: \\server\share\folder

Additional Information

Common Internet File System (CIFS)
Server Message Block (SMB)
Network File System (NFS)
Network Data Management Protocol (NDMP)
Universal Naming Convention (UNC)
Request for Product Qualification (RPQ)
Network-Attached Storage (NAS)

Affected Products

Avamar, Avamar Client

Products

Avamar, Avamar Client, Avamar Client for Windows, Avamar Plug-in for NDMP
Article Properties
Article Number: 000046220
Article Type: Solution
Last Modified: 11 Apr 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.