Systém Avamar a podpora pro sdílené síťové složky mapované na CIFS (SMB) a NFS
Summary: Tento článek vysvětluje, že běžný klient Avamar oficiálně nepodporuje zálohování dat ze sdílených síťových složek CIFS (SMB) a mapovaných NFS. Tuto funkci podporují pouze uzly akcelerátoru NDMP. Pro zvláštní situace existuje zástupné řešení, ale podpora je omezená. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Přestože běžný klient Avamar může zálohovat data z namapovaných jednotek CIFS a exportovaných připojení NFS, tato funkce není oficiálně podporována.
Podpora společnosti Dell nepomáhá s konfigurací nebo odstraňováním problémů souvisejících se zálohováním nebo obnovením těchto dat.
Mezi běžné problémy související se zálohováním sdílených složek CIFS, NFS a SMB patří mimo jiné následující:
Podpora společnosti Dell nepomáhá s konfigurací nebo odstraňováním problémů souvisejících se zálohováním nebo obnovením těchto dat.
Mezi běžné problémy související se zálohováním sdílených složek CIFS, NFS a SMB patří mimo jiné následující:
- Pokud jsou data systému Windows zálohována pomocí klienta UNIX Avamar, dojde ke ztrátě seznamů řízení přístupu (ACL) systému Windows. Naopak, pokud jsou data systému UNIX zálohována pomocí klienta systému Windows, dojde ke ztrátě seznamů ACL systému UNIX.
- Výkon zálohování může být nízký.
- Zákazníci se mohou setkat s problémy třetích stran,
- Zákazníci se mohou setkat s problémy způsobenými interoperabilitou verzí CIFS.
- Neexistuje žádné zařízení pro provádění snímků dat podobných službě VSS umístěných v mapované sdílené složce CIFS nebo NFS. Otevřené soubory nemusí být zálohovány konzistentně.
Cause
Tato funkce není oficiálně podporována.
Výňatek z uživatelské příručky pro klienty zálohování:
"Nepokoušejte se zálohovat sdílenou síťovou složku CIFS/NFS instalací klienta Avamar na místní počítač. Pokud se o to pokusíte, dojde k závažnému snížení výkonu zálohování a obnovení a metadata jako složky, seznamy ACL a oprávnění k souborům se nebudou zálohovat. Chcete-li zálohovat sdílenou složku CIFS/NFS, nainstalujte do sdíleného počítače klienta Avamar nebo zálohujte data pomocí protokolu NDMP."
Výňatek z uživatelské příručky pro klienty zálohování:
"Nepokoušejte se zálohovat sdílenou síťovou složku CIFS/NFS instalací klienta Avamar na místní počítač. Pokud se o to pokusíte, dojde k závažnému snížení výkonu zálohování a obnovení a metadata jako složky, seznamy ACL a oprávnění k souborům se nebudou zálohovat. Chcete-li zálohovat sdílenou složku CIFS/NFS, nainstalujte do sdíleného počítače klienta Avamar nebo zálohujte data pomocí protokolu NDMP."
Resolution
Úložná zařízení, jako jsou soubory NAS, by měla být zálohována pomocí akcelerátoru Avamar Network Data Management Protocol (NDMP).
Uzel akcelerátoru Avamar NDMP je vyhrazený klient Avamar. Běží na něm běžný klientský software Avamar Linux a modul plug-in Avamar NDMP pro zálohování dat z podporovaných filtrů pomocí protokolu NDMP.
Informace o funkci akcelerátoru NDMP jsou k dispozici v příručce k akcelerátoru NDMP Avamar, případně se můžete obrátit na obchodního zástupce EMC.
Pokud má systém exportující data pomocí CIFS nebo NFS operační systém, který podporuje software Avamar, nainstalujte do něj klienta a shromažďujte soubory přímo.
Pokud je to možné, měl by být server, který je hostitelem sdílených složek CIFS, NFS nebo SMB, zálohován přímo pomocí klienta nainstalovaného v systému souborů.
Alternativní řešení:
První krok:
Zákazník musí odsouhlasit a odpovědět e-mailem, že přijímá a plně chápe, že podpora je omezená, a souhlasit s následujícími podmínkami.
Zákazník si níže uvedená omezení přečetl a plně jim rozumí.
Mezi běžné problémy související se zálohováním sdílených složek CIFS, NFS a SMB patří mimo jiné následující:
Druhý krok:
Zákazník musí vybrat nebo vytvořit účet, který má plné oprávnění správce (správce domény) ke zdroji sdílené složky.
Krok 3:
Na klientovi použitém k provedení zálohy nastavte službu "Backup Agent" tak, aby se přihlásila jako účet v kroku 2.
Krok čtyři:
Pro zálohování definujte konkrétní datovou sadu a zadejte cestu ke sdílené složce ve formátu UNC.
Na kartě "Zdrojová data" v možnostech zásuvného modulu:
NEZAHRNUJTE všechny místní systémy souborů Windows nebo vyberte Všechny místní systémy souborů Windows. Ve výchozím nastavení je vybrán veškerý místní systém souborů Windows. Tím se zálohují všechna data systému souborů.
Zákazník musí omezit datovou sadu na konkrétní položky a provést následující kroky:
a. Do pole File or Folder Path zadejte cestu jako příklad: \\server\sdílená\složka
B. Klikněte na tlačítko ADD.
V případě obnovení musí být cílová složka zadána jako příklad: \\server\sdílená\složka
Uzel akcelerátoru Avamar NDMP je vyhrazený klient Avamar. Běží na něm běžný klientský software Avamar Linux a modul plug-in Avamar NDMP pro zálohování dat z podporovaných filtrů pomocí protokolu NDMP.
Informace o funkci akcelerátoru NDMP jsou k dispozici v příručce k akcelerátoru NDMP Avamar, případně se můžete obrátit na obchodního zástupce EMC.
Pokud má systém exportující data pomocí CIFS nebo NFS operační systém, který podporuje software Avamar, nainstalujte do něj klienta a shromažďujte soubory přímo.
Pokud je to možné, měl by být server, který je hostitelem sdílených složek CIFS, NFS nebo SMB, zálohován přímo pomocí klienta nainstalovaného v systému souborů.
Alternativní řešení:
První krok:
Zákazník musí odsouhlasit a odpovědět e-mailem, že přijímá a plně chápe, že podpora je omezená, a souhlasit s následujícími podmínkami.
Zákazník si níže uvedená omezení přečetl a plně jim rozumí.
Mezi běžné problémy související se zálohováním sdílených složek CIFS, NFS a SMB patří mimo jiné následující:
- Pokud jsou data systému Windows zálohována pomocí klienta UNIX Avamar, dojde ke ztrátě seznamů řízení přístupu (ACL) systému Windows. Naopak, pokud jsou data systému UNIX zálohována pomocí klienta systému Windows, dojde ke ztrátě seznamů ACL systému UNIX.
- Výkon zálohování může být nízký.
- Zákazníci se mohou setkat s problémy třetích stran,
- Zákazníci se mohou setkat s problémy způsobenými interoperabilitou verzí CIFS.
- Neexistuje žádné zařízení pro provádění snímků dat podobných službě VSS umístěných v mapované sdílené složce CIFS nebo NFS. Otevřené soubory nemusí být zálohovány konzistentně.
- Podpora je omezená a poskytuje se jako maximální úsilí.
Druhý krok:
Zákazník musí vybrat nebo vytvořit účet, který má plné oprávnění správce (správce domény) ke zdroji sdílené složky.
Krok 3:
Na klientovi použitém k provedení zálohy nastavte službu "Backup Agent" tak, aby se přihlásila jako účet v kroku 2.
Krok čtyři:
Pro zálohování definujte konkrétní datovou sadu a zadejte cestu ke sdílené složce ve formátu UNC.
Na kartě "Zdrojová data" v možnostech zásuvného modulu:
NEZAHRNUJTE všechny místní systémy souborů Windows nebo vyberte Všechny místní systémy souborů Windows. Ve výchozím nastavení je vybrán veškerý místní systém souborů Windows. Tím se zálohují všechna data systému souborů.
Zákazník musí omezit datovou sadu na konkrétní položky a provést následující kroky:
a. Do pole File or Folder Path zadejte cestu jako příklad: \\server\sdílená\složka
B. Klikněte na tlačítko ADD.
V případě obnovení musí být cílová složka zadána jako příklad: \\server\sdílená\složka
Additional Information
Protokol CIFS (Common Internet File System) Blok zpráv serveru (SMB)
Síťový systém souborů (NFS)
Protokol NDMP (Network Data Management Protocol)
UNC (Universal Naming Convention)
Požadavek na kvalifikaci produktu (RPQ)
Úložiště NAS (Network Attached Storage)
Síťový systém souborů (NFS)
Protokol NDMP (Network Data Management Protocol)
UNC (Universal Naming Convention)
Požadavek na kvalifikaci produktu (RPQ)
Úložiště NAS (Network Attached Storage)
Affected Products
Avamar, Avamar ClientProducts
Avamar, Avamar Client, Avamar Client for Windows, Avamar Plug-in for NDMPArticle Properties
Article Number: 000046220
Article Type: Solution
Last Modified: 11 Apr 2024
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.