Avamar: Backupperformance wird durch Echtzeit-Datei-Scan der Virenschutzsoftware beeinträchtigt
Summary: Virenschutzsoftware für das Scannen von Dateien in Echtzeit beeinträchtigt die Backup- oder Wiederherstellungsperformance des Avamar Clients.
Symptoms
Folgende Bedingungen liegen vor:
- Die Statusmeldungen im Client-Protokoll zeigen eine geringe CPU-Auslastung durch
avtar.exe(siehe Dell Artikel Avamar – So interpretieren Sie Statuszeilen im avtar-Backupprotokoll). - Das Backup wird nicht durch die Überlastung des Netzwerks beeinträchtigt.
- Auf dem Client ist Virenschutzsoftware installiert.
- Die Virenschutzsoftware ist so eingestellt, dass sie Dateien „bei Zugriff“ (wenn eine Anwendung auf Dateien zugreift) in Echtzeit scannt.
- Registerkarte Prozesse > Ansicht > wählen Sie Spalten aus.
- Aktivieren Sie die Spalten I/O Read Bytes und I/O Reads.
- Überwachen Sie während eines Backups den Virenschutzprozess.
- Wenn die I /O -Lesebytes oder I/O -Lesevorgänge für die Virenschutzanwendung während des Backups stark erhöht werden, kann dies auf ein Problem hinweisen.
Cause
Der Virenschutz-Scan bei Zugriff konkurriert mit dem avtar -Prozess um die Storage-I/O durch Abfangen von Dateien, auf die avtar versucht, darauf zuzugreifen.
Das Virenschutzprogramm durchsucht möglicherweise Snapshot-Speicher mit Inhalt avtar -Prozess um den Zugriff auf den Snapshot, der als Teil des Backups erstellt wurde, konkurriert.
Diese zusätzliche Last auf der Storage-Hardware reduziert die potenzielle Datei-Scan-Geschwindigkeit des Backups.
Resolution
Konfigurieren Sie vorübergehend eine virtuelle Testmaschine (VM), um ein Backup auf Client-Ebene ohne installiertes Antivirenprogramm durchzuführen, das Timing der Aufzeichnungen, installieren Sie dann das Antivirenprogramm und vergleichen Sie.
Vergleichen Sie die Performance des letzten Backups mit früheren Backups, bei denen der Echtzeitscan aktiv war. Überprüfen Sie dazu ein vollständiges Client-Protokoll auf Backed-up.
Fügen Sie --status=120 manuell unter „Zusätzliche Optionen“ hinzu, um die Häufigkeit der Statusmeldungen für Testzwecke zu erhöhen.
avtar Info <6083>: Backed-up 344.3 GB in 862.43 minutes: 24 GB/hour (1,508,688 files/hour)
Zusätzlich zu den
avtar.exesind nachfolgend die ausführbaren Dateien aufgelistet, die als vertrauenswürdig festgelegt oder vom ZUGRIFFS-SCAN des Virenschutzes ausgeschlossen werden sollten. Die Dateien werden in der Regel im Ordner c:\program files\avs\bin installiert:
avsql.exe Microsoft SQL Server avexchglr.exe Exchange Server GLR avexvss.exe Exchange Server axionfs.exe Exchange Server GLR avoracle.exe Oracle avlotus.exe Lotus Notes avscc.exe Desktop Icon avagent.exe Communication service between the client and Avamar server avvss.exe Disaster Recovery, BMR avmossvss.exe SharePoint Servers avupdate.exe Client update tool
- Ausschließen des Verzeichnisses:
- Suchen Sie die Virenschutzeinstellungen: Suchen Sie die Einstellungen oder das Konfigurationsfenster Ihrer Antivirensoftware.
- Ausschlussliste für Zugriffsscans: Navigieren Sie zu dem Abschnitt zum Hinzufügen oder Verwalten von Scanausschlüssen, der oft als "Ausschlüsse","Scan-Ausschlussliste" oder ähnlich gekennzeichnet ist.
- Fügen Sie das Verzeichnis hinzu: Geben Sie den Pfad ein oder fügen Sie ihn ein.
\Device\HardDiskVolumeShadowCopy*in die Ausschlussliste ein und speichern Sie die Änderungen.
-
Ausschluss des Prozesses:
- Suchen Sie die Virenschutzeinstellungen: Suchen Sie die Einstellungen oder das Konfigurationsfenster Ihrer Antivirensoftware.
- Zugriffsprozessausschlüsse: Suchen Sie den Abschnitt zum Hinzufügen oder Verwalten von Prozessausschlüssen.
- Fügen Sie den Prozess hinzu: Hinzufügen
"vssvc.exe"in die Liste der ausgeschlossenen Prozesse ein.
Um den absoluten Pfad des Schatten-Volume aufzulisten, verwenden Sie eine Eingabeaufforderung mit erhöhten Rechten und führen Sie den Befehl "vssadmin List Shadows"-Befehl.
\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy*\
\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy*
Wenn die Backupperformance nach der Behebung dieser Art von Beeinträchtigung durch Virenschutzsoftware immer noch langsam ist, lesen Sie folgenden Dell Artikel: Langsame Avamar-Backupperformance – Troubleshooting und Identifizieren von Engpässen (LÖSUNGSPFAD)
Additional Information
Das beschriebene Verhalten tritt bei jedem Antivirenprogramm auf, das Scans in Echtzeit oder bei Zugriff durchführt.
Im Folgenden finden Sie Links zu empfohlenen Artikeln in der Onlinedokumentation verschiedener Virenschutzanbieter, in denen das Verhalten oder dessen Eindämmung erläutert wird.
Einige Virenschutzprogramme speichern Hash- oder MD5-Prüfsummen von ausgeschlossenen oder sicher gelisteten Programmen. Beim Upgrade der Avamar-Software muss der Hash oder die MD5-Prüfsumme gemäß den Anforderungen des Softwareanbieters neu berechnet werden.
Symantec EndPoint Protection
- Broadcom Backup Exec oder Backup Exec System Recovery: Backup- und Wiederherstellungsjobs sind langsamer als erwartet, wenn Symantec Endpoint Protection 12.1 installiert ist (obwohl der Artikel sich speziell mit Symantecs eigener Backupsoftware beschäftigt, tritt das Problem bei jeder Backuplösung auf)
- Broadcom EndPoint Protection-Ausschlüsse für Backup Exec
Trend Micro Office scan
- Dell Artikel Anleitung zum Überprüfen, ob sich Echtzeit-Scans des Trend Micro-Virenschutzes auf die Avamar Client-Performance auswirken (Anmeldung beim Dell Support erforderlich, um diesen Artikel anzuzeigen)
- Trend Empfohlene Scan-Ausschlussliste für Trend Micro EndPoint-Produkte
- Trend Ausschluss von Volume-Schattenkopien aus dem Echtzeit-Scan von Dell APEX One
Sophos
- Sophos Ausschlüsse verarbeiten (Windows)
- Dell Artikel Mangelhafte Backupperformance auf Avamar Client mit Sophos-Virenschutz
- Sophos Central Server: Festlegen des Scan-Ausschlusses für Volume-Schattenkopien
Quick Heal Endpoint Security
ESET Endpoint Anti-Virus
- ESET Endpoint 7 Ausschlüsse werden verarbeitet
Panda Security
CrowdStrike
- CrowdStrike Whitelisting
Microsoft
- Microsoft-Virenschutzrichtlinie für Endpunktsicherheit in Intune
- Microsoft Defender für Endpunkt
- Microsoft Hinzufügen eines Dateityp- oder Prozessausschlusses zur Windows-Sicherheit
Carbon Black
Fortinet
Trellix (FireEye)
- Trellix EndPoint Security xAgent-Administrationshandbuch – Aktivieren einer nutzerdefinierten Richtlinie
Cisco AMP
Rapid7