Avamar: Kapasiteetin vianmääritys, ongelmat ja kysymykset – koko kapasiteetti (ratkaisupolku)
Summary: Tätä ratkaisupolkuartikkelia voidaan käyttää lähtökohtana kaikille Avamarin kapasiteettiongelmille.
Symptoms
Kapasiteetti voidaan nähdä datana tai levytilana, jota asiakas käyttää palvelimessa asiakastietojen varmuuskopiointitöihin.
Kapasiteettiongelmat voivat estää palvelimen normaalia toimintaa lisäämästä uusia tietoja tai joskus sallimasta vanhojen tietojen puhdistamista ja poistamista.
- Harjoittelu
- Koulutus
- Kysymyksiä
- Roskienkeruun (GC) vikojen ongelmat
- Käyttöjärjestelmän (OS) kapasiteettiongelmat
GSANKapasiteettiin liittyvät ongelmat- Metatietojen kapasiteettiongelmat
- Data Domain (DD) -integraation kapasiteettiongelmat
Cause
Tämä ratkaisu auttaa määrittämään koetun ongelman tyypin ja tavat sen ratkaisemiseksi.
Resolution
Varmista, että kaikki alla olevat vianmäärityksen vaiheet toteutuvat ympäristössäsi. Jokainen vaihe tarjoaa ohjeita tai linkin asiakirjaan mahdollisten syiden poistamiseksi ja korjaavien toimenpiteiden toteuttamiseksi tarvittaessa. Vaiheiden järjestys on mahdollisimman asianmukainen, jotta ongelma voidaan eristää ja oikea ratkaisu löytää. Älä ohita vaiheita. Jos kapasiteetissa on useita ongelmia, jotka ilmenevät eri tavoin, myös ne on käsiteltävä tietyssä järjestyksessä.
Vaikka useimmissa vaiheissa mainitaan vain Avamar, sekä Avamar - NetWorker- että Avamar - Data Domain -integraatiot voivat silti aiheuttaa monia alla olevista ongelmista.
Vaihe 1: Tietojen kerääminen: Yleensä Avamarin kapasiteettiongelmien ymmärtämiseksi "maalaa kuva", jotta näet koko ongelman ja tilanteen. Joskus yksi kapasiteetin näkökohta voi vaikuttaa toiseen, tai jotkut eivät ehkä ymmärrä aluksi, että on olemassa useita ongelmia. Vianmäärityksen voi aloittaa ymmärtämällä ongelman täysin.
Katso Avamar: Kapasiteettiongelmien vianmääritykseen tarvittavien tietojen kerääminen tiedonkeruuta varten.
Vaihe 2: Yleissivistävä ja ammatillinen koulutus: Jos asiakas haluaa koulutusta tai ymmärrystä siitä, miten kapasiteetti toimii, mitä tietyt arvot tarkoittavat ja niin edelleen, tätä artikkelia voidaan käyttää. On silti hyvä idea ymmärtää heidän ongelmansa ja "maalata kuva", koska kysymykset tai koulutus voivat usein olla seurausta kapasiteettiongelmista.
Katso kohtaa Avamar Capacity General Training - Koulutusongelmien ratkaisupolku .
Vaihe 3: Suuri käyttöjärjestelmäkapasiteetti: Tarkista vaiheessa 1 kerätystä tuloksesta OS Capacity -arvot. Käyttöjärjestelmän kapasiteettia rajoittaa kaikkien osioiden KORKEIN käyttöarvo, vaikka muut osiot olisivat pienempiä. Suurin arvo on "rajoittava tekijä" ja sitä on vähennettävä.
Jos solmun osion suurin käyttöarvo ylittää 89 %, katso lisätietoja kohdasta Avamar OS Capacity (ratkaisupolku)
Vaihe 4: Roskienkeräysvirhe tai -virheet: Jos Avamar Garbage Collection -työ tuottaa kerätystä tuloksesta virheilmoituksia, ongelma on korjattava ennen jäljellä olevia kapasiteettiongelmia.
Lisätietoja tämäntyyppisestä ongelmasta on kohdassa Avamar - Jätteiden keräysvirheiden (GC) vianmääritys (ratkaisupolku)
Vaihe 5: Suuri GSAN-kapasiteetti: Jos käyttöjärjestelmän kapasiteettiongelmia ei löydy ja GC ei näytä virhesanomia, tarkista kerätystä tuloksesta GSAN Kapasiteettiarvot:
Alkaen status.dpn, arvo 65% tarkoittaa, että ruudukko on täynnä (eli "admin" -tila tai vain luku -tilassa) eikä kapasiteetin kasvulle ole enää tilaa.
GSAN Kapasiteetti on noin 63% (ns. disknormaldelta)
Lisätietoja näistä tilanteista on kohdassa Avamar GSAN (tai käyttäjä) Kapasiteetti (ratkaisupolku)
Vaihe 6: Metatietojen kapasiteetti: Kun Data Domain integroidaan Avamariin, otetaan käyttöön uusi kapasiteettirajoitus: metatietojen kapasiteetti. Metatietojen kapasiteetti tarkoittaa Avamarin kapasiteettia.
Data Domain -integrointien avulla tiedot voidaan ohjata ja lähettää Data Domainiin tallennusta varten, mutta Avamar säilyttää silti varmuuskopiotiedostojen metatiedot Avamarissa. Avamar seuraa tätä metatietojen kapasiteettia metatietokapasiteettina.
Kun vaiheet 1–5 on tarkistettu ja kaikki kapasiteettiin liittyvät ongelmat ratkaistu, tarkista metatietojen kapasiteetin ratkaisu Avamarin metatietokapasiteetin ratkaisupolusta.
Vaihe 7: High Data Domain -kapasiteetti: Kun Data Domain on integroitu Avamariin, Data Domain -palvelin itsessään täyttää kapasiteettinsa.
Seuraava ratkaisupolkua käsittelevä artikkeli: auttaa määrittämään:
- Mitkä Avamarin mahdolliset ongelmat voivat aiheuttaa Data Domain -kapasiteetin kasvua tai täyttymistä.
- Data Domainiin liittyvät ongelmat
- Data Domain on täynnä Avamarista riippumattomista syistä.
Kun vaiheet 1–6 on käyty läpi ja kaikki kapasiteettiin liittyvät ongelmat ratkaistu, tarkista Data Domain High Capacity Avamar-integroinnin ratkaisupolusta
Muut asiat: Näitä voidaan edelleen pitää huolenaiheina tai ongelmiin, jotka vaikuttavat kapasiteettiin:
- Replikoinnin lähde ja kohdekapasiteetti eivät vastaa toisiaan: Kun tietoja replikoidaan Avamarin tai minkä tahansa integroidun tuotteen kanssa, kapasiteetin odotetaan vastaavan replikoinnin lähde- ja replikoinnin kohderuudukkoa.
GSAN kapasiteettia MOLEMMISSA sähköverkoissa, mutta edellyttää aina lisävalidointien suorittamista replikointikonfiguraation ja työn tilan ympärillä siltä varalta, että käytettävissä on muita kapasiteettiin liittyviä ongelmia: Avamar: Replikoiva pari näyttää kapasiteetin käytön eri tasot. Kuinka tutkia syitä.
- Management Console Server (MCS) ilmoittaa seuraavasta ilmoituksesta:
2012/10/06-21:11:09.75264 {0.4} [manage:3070] ERROR: <0001> diskinfo::update invalid disk space parameters dev=831 total=1906261MB avail=1675818MB reserved=223410MB maxmb=223978MB newavail=1675818MB reservedoverflow=1 availmboverflow=0
Tämä on MC-käyttöliittymän raitakapasiteettia koskeva raportointiongelma, joka liittyy vain epämääräisesti muihin tässä käsiteltyihin kapasiteettiaiheisiin. Tällä ei ole havaittu muuta vaikutusta kuin viestin näkeminen käyttöliittymässä.
- Kapasiteettiennusteraportit: