Avamar: Solução de problemas, problemas e dúvidas de capacidade – toda a capacidade (caminho de resolução)

Summary: Este artigo do caminho de resolução pode ser usado como ponto de partida para todos os problemas de capacidade do Avamar.

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Symptoms

A capacidade pode ser vista como os dados ou o espaço em disco usado em um servidor pelos trabalhos de backup de dados do client.

Problemas de capacidade podem impedir que a funcionalidade normal do servidor adicione novos dados ou, às vezes, permitir que dados antigos sejam limpos e removidos.

 

Os chamados podem ser abertos para resolver vários problemas de capacidade, como:
  • Treinamento
  • Instituições educacionais
  • Perguntas
  • Problemas com falhas de coleta de lixo (GC)
  • Problemas de capacidade do sistema operacional (SO)
  • GSAN Problemas de capacidade
  • Problemas de capacidade de metadados
  • Problemas de capacidade de integração do Data Domain (DD)

Cause

Há vários fatores a serem considerados ao abordar problemas de capacidade em uma grade do Avamar. A distinção mais importante ao lidar com problemas de capacidade é determinar que tipo de problema de capacidade isso pode estar relacionado. 

Essa solução ajuda a determinar o tipo de problema enfrentado e as maneiras de resolvê-lo.

Resolution

Confirme se cada etapa de solução de problemas abaixo é verdadeira para seu ambiente. Cada etapa fornece instruções ou um link para um documento, a fim de eliminar possíveis causas e tomar ações corretivas conforme necessário. As etapas são ordenadas na sequência mais apropriada para isolar o problema e identificar a resolução adequada. Não pule uma etapa. Se houver vários problemas ocorrendo de maneiras diferentes com a capacidade, eles também devem ser abordados em uma ordem específica.

Embora a maioria das etapas mencione apenas o Avamar, as integrações "Avamar - NetWorker" e "Avamar - Data Domain" ainda podem produzir muitos dos problemas abaixo.

 

Etapa 1: Coleta de informações: Geralmente, para entender os problemas de capacidade do Avamar, basta "pintar um quadro" para ver todo o problema e a situação. Às vezes, um aspecto da capacidade pode afetar outro, ou alguns podem não perceber inicialmente que há vários problemas. Para iniciar a solução de problemas, você deve ter uma compreensão completa do problema.

Consulte Avamar: Como coletar informações necessárias para solucionar problemas de capacidade para coleta de informações.

 

Etapa 2: Educação e Treinamento: Se um cliente estiver buscando orientação ou entendendo como a capacidade funciona, o que certos valores significam e assim por diante, este artigo pode ser usado. Ainda é uma boa ideia entender seus problemas e "pintar um quadro", porque perguntas ou educação muitas vezes podem ser o resultado de problemas de capacidade.

Consulte Avamar Capacity General Training - Resolution Path for Education and Training-related capacity issues.

 

Etapa 3: Alta capacidade do SO:  Na saída coletada na Etapa 1, verifique os valores de capacidade do SO. A capacidade do SO é limitada pelo valor de uso MAIS ALTO em todas as partições, mesmo que outras sejam menores. O valor mais alto é o "fator limitante" e deve ser reduzido.

Se o maior valor de uso de qualquer partição de nó exceder 89%, consulte Capacidade do SO do Avamar (caminho de resolução)

Nota: Se a diferença entre os valores de partição mais altos e mais baixos em um nó de dados for de 20% ou mais, a capacidade do SO do Avamar (caminho de resolução) também se aplicará.
 
 

Etapa 4: Erro ou falhas de coleta de lixo: Na saída coletada, se um trabalho de coleta de lixo do Avamar gerar mensagens de erro, elas deverão ser resolvidas em seguida antes dos tipos restantes de problemas de capacidade.

Para esse tipo de problema, consulte Avamar — solução de problemas de falhas de coleta de lixo (GC) (caminho de resolução)

 

Etapa 5: Alta capacidade de GSAN:  Na saída coletada, se não houver problemas de capacidade do SO e a GC não estiver mostrando mensagens de erro, analise o GSAN Valores de capacidade: 

De status.dpn, um valor de 65% significa que a grade está cheia (também conhecido como modo "admin" ou somente leitura) e não há mais espaço para o crescimento da capacidade.

Nota: também é possível ver o modo "admin" ou somente leitura quando o GSAN A capacidade é de cerca de 63% (devido a algo chamado disknormaldelta)
 

Para essas situações, consulte Avamar GSAN (ou Usuário) Capacidade (caminho de resolução)

 

Etapa 6: Capacidade de metadados:  Quando um Data Domain é integrado ao Avamar, um novo limite de capacidade é introduzido: Capacidade de metadados. A capacidade de metadados é a capacidade encontrada no próprio Avamar.

Com as integrações do Data Domain, os dados podem ser direcionados e enviados ao Data Domain para armazená-los, mas o Avamar ainda contém os metadados dos arquivos de backup no Avamar. O Avamar rastreia essa capacidade de metadados como Capacidade de metadados.

Depois que as etapas de 1 a 5 forem analisadas e quaisquer problemas relacionados à capacidade resolvidos, analise a resolução da capacidade de metadados no Avamar Metadata Capacity Resolution Path.

 

Etapa 7: Alta capacidade do Data Domain:  Quando um Data Domain é integrado ao Avamar, o próprio servidor do Data Domain pode preencher sua capacidade.

O seguinte artigo do caminho de resolução: Ajuda a determinar:

  • Quais possíveis problemas do Avamar podem fazer com que a capacidade do Data Domain aumente ou se encha
  • Alguns problemas específicos do Data Domain
  • Se o Data Domain estiver cheio por motivos não relacionados ao Avamar.

Depois que as etapas de 1 a 6 forem analisadas e quaisquer problemas relacionados à capacidade resolvidos, analise Data Domain High Capacity no Avamar Integration Resolution Path

 
 

Outras questões: Isso ainda pode ser visto como preocupações ou problemas que afetam a capacidade:

  • A capacidade de origem e destino da replicação não corresponde: Ao replicar dados com o Avamar ou qualquer produto integrado, espera-se que a capacidade corresponda aos grids de origem e destino de replicação.
Isso se enquadra na verificação do GSAN capacidade em AMBOS os grids, mas sempre exige que validações adicionais sejam realizadas em torno da configuração de replicação e do status do trabalho caso haja outros problemas relacionados à capacidade em mãos: Avamar: Um par de replicação mostra diferentes níveis de uso da capacidade. Como investigar as causas. 
 
  • O Management Console Server (MCS) relata a seguinte mensagem:
2012/10/06-21:11:09.75264 {0.4} [manage:3070]  ERROR: <0001> diskinfo::update invalid disk space parameters dev=831 total=1906261MB avail=1675818MB reserved=223410MB maxmb=223978MB newavail=1675818MB reservedoverflow=1 availmboverflow=0 

Esse é um problema de geração de relatórios sobre a capacidade de fração na interface do usuário (IU) do MC apenas vagamente relacionado aos outros tópicos de capacidade discutidos aqui. Não há nenhum impacto detectado disso, além de ver a mensagem na interface do usuário.

Outros detalhes podem ser encontrados aqui:
 
  • Relatórios de previsão de capacidade:

 


 

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000163006
Article Type: Solution
Last Modified: 06 Mar 2025
Version:  11
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