PowerStore: After an upgrade to PowerStoreOS 4.1 on clusters with three or more appliances, management database replication may remain in async mode
Summary: Following an upgrade to PowerStoreOS version 4.1 on a cluster with three or more appliances, the cluster may fail to re-enable synchronous replication of internal management database. In this case, management database replication on the affected cluster remains in asynchronous mode. ...
Symptoms
After an upgrade to version 4.1, the internal management database does not revert back to synchronous replication and remains asynchronous.
Note: This issue does not affect single appliance clusters, or clusters with two appliances.
This change should not pose any immediate impact to cluster functionality, or to user data as changes are replicated to all appliances.
A potential data integrity condition may be triggered on the management database of a cluster with three or more appliances following an appliance failover event (such as, appliance-level shutdown, appliance-level power outage).
Cause
Due to a software issue in version 4.1 (or later), management database replication on a cluster with three or more appliances does not revert back to synchronous replication after upgrade completion, and remains asynchronous.
Impact
If the primary appliance abruptly fails, or disconnects, and if there are pending management commands that were not yet sent to at least one secondary appliance, a data integrity condition may be triggered on the management database of the affected cluster.
Resolution
This issue is fixed in PowerStoreOS v4.1.0.1 and v4.2 and higher.
Contact Dell Technical Support to confirm this issue has occurred. Reference this knowledge base article ID for expedited handling.
Note: With the release of PowerStore Health Check package 4.1 a new pre-upgrade Health Check (PUHC) was introduced to identify appliance clusters with 3 or 4 PowerStore appliances. The new check with flag such systems and will cause PUHC to PowerStoreOS version 4.1 to fail.
