Dell Business Dock WD15, Dell Thunderbolt Dock TB16, and Dell Precision Dual USB-C Thunderbolt Dock TB18DC Legacy Support
Summary: Learn about Dell Business Dock WD15, Dell Thunderbolt Dock TB16, and Dell Precision Dual USB-C Thunderbolt Dock TB18DC Legacy Support.
Symptoms
Dell ended docking station production for WD15, TB16, and TB18DC USB Type-C docks on April 30, 2020. If your dock is still under warranty, Dell continues to provide technical support for docking issues with a supported laptop or workstation. Dell commercial laptops or workstations not in the compatibility list, the following table outlines the functionality and limitations of using WD15/TB16 dock with the unsupported computer.
| WD15/TB16 Dock | Dell Commercial Laptops |
|---|---|
| Power Delivery to laptop | Yes |
| Display support through video ports | Yes (As per display resolution support specified in the user guide) |
| Data transfer through USB ports | Yes |
| Audio through analog audio ports | Yes |
| Wired Ethernet through RJ45 port | Yes |
| The dock power button emulates the computer power button. | Yes |
| MAC address pass-through | Yes |
| Wake on Dock | Yes |
| Wake-on-LAN | Yes |
| Firmware update over computer native operating system (Firmware Update Utility) | Depends on the Computer, See User Manual for more information. |
| Technical Support for issues related to Dock or Dock functionality. | Yes, if the dock is within the warranty period. |
Cause
In general, the standard warranty period for these docks that are purchased on a standalone basis is one year from the date of purchase. If purchased with a supported computer, the dock warranty period typically matches the warranty period for the supported computer with which the dock was purchased.
Resolution
Docks and supported computers that are still in-warranty:
- If your laptop or workstation is listed as being supported for your dock, Dell provides technical support in case you face any covered docking issue during the warranty period.
- If your laptop or workstation is not listed as being supported for your dock, test your dock with a supported computer to see if the docking issue can be reproduced on a supported computer. If the docking issue can be reproduced on a supported computer, Dell provides necessary support to help resolve warranty-covered issues for the dock on the supported computer.