RecoverPoint for VMs: Consistency group non SINCRONIZZATO dopo l'attività di failover

Summary: Consistency group non SINCRONIZZATO dopo l'attività di failover

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La GUI del plug-in RecoverPoint non si aggiorna correttamente, ad esempio potrebbe verificarsi il seguente comportamento:Dopo

l'esecuzione di un attività di failover, il consistency group non è stato in grado di completare la sincronizzazione.
Dai registri di mango (/var/log/tomcat8_9/mango-debug.log):
2024-03-23 09:45:27.911 ERROR – [http-nio-9020-exec-8] BaseCommand                              : failed to Validate Failover, command=ValidateFailoverCommand(copyId=733820340_5b3cdb93e47a8120_0, startTransfer=false, failoverParameters=FailoverParameters(applyFailoverNetworks=true), targetCopyId=GlobalCopyID [localCopyID=LocalCopyID [id=0], siteUID=SiteUID [6574370984293990697]], groupUID=GroupUID [id=733820340], groupSettingsChangesParam=GroupSettingsChangesParam [groupUID=GroupUID [id=733820340], CG_NAME,
Dai registri dei mietitori (/var/log/tomcat8_9/reaper-db.log)
2024-03-22 16:31:16.483  INFO – [pool-102-thread-1] InMemoryDBManageServiceImpl              : Initializing repository for vm
2024-03-22 16:31:16.484 ERROR – [pool-102-thread-1] InitDBManagerService                     : initializing with ProtectedVmsOutOfSync has failed, by exception: com.arangodb.springframework.ArangoUncategorizedException: Response: 500, Error: 1104 - IO error: No space left on deviceWhile appending to file: /var/lib/arangodb3/engine-rocksdb/journals/3721104.log: No space left on device; nested exception is com.arangodb.ArangoDBException: Response: 500, Error: 1104 - IO error: No space left on deviceWhile appending to file: /var/lib/arangodb3/engine-rocksdb/journals/3721104.log: No space left on device

Cause

ArangoDB riscontra un errore di I/O, con conseguente messaggio di errore "No space left on device" nei registri. Questo problema specifico si verifica durante le operazioni di I/O elevato con ArangoDB ed è correlato a una perdita di memoria.

Resolution

Soluzione alternativa:

Per risolvere questo problema, applicare lo script riportato di seguito:
  • Accedere a RPA1 e RPA2 per ogni cluster utilizzando SSH.
  • Accedi con l'account amministratore
  • Seleziona le opzioni:
    • [2] Configurazione
    • [8] Opzioni avanzate
    • [4] Eseguire lo script
    • Incolla script:
MzRiMmJkZWVlMmRkMmU5ZTRkYjc1YjlmNmMxMmU0MzIKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk
ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOlJQRUUtMzY2MgpyZXN0YXJ0IGFyYW5nbwpJYW4gUmFu
c3Ryb20KIyEvYmluL2Jhc2gKcHJpbnRmICcjIS9iaW4vYmFzaFxuXG5sb2dfZmlsZT0iL3Zhci9s
b2cvdG9tY2F0OS9yZWFwZXItZGIubG9nIlxudGV4dF90b19zZWFyY2hfZm9yPSJObyBzcGFjZSBs
ZWZ0Ilxuc2VydmljZV9uYW1lPSJhcmFuZ29kYjMuc2VydmljZSJcblxuZWNobyAiJChkYXRlKSAt
LSBFeGVjdXRpb24gc3RhcnRlZC4gQ2hlY2tpbmcgZm9yIGFyYW5nb2RiMyBtZW1vcnkgaXNzdWUg
aW4gJGxvZ19maWxlIlxudGFpbCAtbiAxMDAgIiRsb2dfZmlsZSIgfCBncmVwIC1xICIkdGV4dF90
b19zZWFyY2hfZm9yIlxuaWYgWyAkPyAtZXEgMCBdOyB0aGVuXG4gICAgIyBJZiB0aGUgdGV4dCBp
cyBmb3VuZCwgcmVzdGFydCB0aGUgc2VydmljZVxuICAgIGVjaG8gIiQoZGF0ZSkgLS0gRm91bmQg
QXJhbmdvRGIgaXNzdWUuIFJlc3RhcnRpbmcgJHNlcnZpY2VfbmFtZSJcbiAgICBzdWRvIHN5c3Rl
bWN0bCByZXN0YXJ0ICIkc2VydmljZV9uYW1lIlxuZWxzZVxuICAgICAgICBlY2hvICIkKGRhdGUp
IC0tIE5vIGFyYW5nb2RiMyBpc3N1ZSBmb3VuZC4gRXhpdGluZyB0aGUgc2NyaXB0LiJcbmZpJyA+
PiAvaG9tZS9rb3Mva2JveC9zcmMvaW5zdGFsbGF0aW9uL2Rpc3RyaWJ1dGlvbi9hcmFuZ29kYl9y
ZXN0YXJ0LnNoCmNobW9kIDc3NyAvaG9tZS9rb3Mva2JveC9zcmMvaW5zdGFsbGF0aW9uL2Rpc3Ry
aWJ1dGlvbi9hcmFuZ29kYl9yZXN0YXJ0LnNoCmVjaG8gIiovMzAgKiAqICogKiAgICByb290ICAg
IC9ob21lL2tvcy9rYm94L3NyYy9pbnN0YWxsYXRpb24vZGlzdHJpYnV0aW9uL2FyYW5nb2RiX3Jl
c3RhcnQuc2ggPj4gL3RtcC9yZXN0YXJ0X2FyYW5nb2RiLmxvZyIgPj4gL2V0Yy9jcm9udGFiCg==
#
  • Applicare lo script a RPA1 e RPA2 su ciascun cluster RecoverPoint.
  • Riavviare RPA dopo l'applicazione dello script.
  • Eseguire un RPA alla volta.
Risoluzione:

Dell Technologies Engineering sta attualmente esaminando il problema. Non è ancora disponibile una correzione permanente. Per assistenza, contattare il centro di assistenza clienti Dell Technologies o il responsabile dell'assistenza e fare riferimento a questo ID soluzione.
 

Article Properties
Article Number: 000225007
Article Type: Solution
Last Modified: 30 Aug 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.