NetWorker: Kan ikke logge på NMC med AD/LDAP-kontoen "Unable to login, verify that the authentication service on [servername] is running" (Kan ikke logge på, kontroller at godkjenningstjenesten på [servernavn] kjører)
Summary: Kan ikke logge på NMC etter oppgradering, feil med kan ikke logge på, kontrollere at godkjenningstjenesten på [servernavn] kjører
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Når du logger på NetWorker Management Console (NMC) med en AD/LDAP-konto, vises følgende feil: "Unable to login, verify that the authentication service on [servername] is running"
"NMC server's gstd.raw may report:
servername.domain gstd NSR error 78 Unable to login, verify that the authentication service on %s is running: [%s] Autentiseringstjenesten 2 0 21 servername.domain 0 37 er ikke tilgjengelig
"NMC server's gstd.raw may report:
servername.domain gstd NSR error 78 Unable to login, verify that the authentication service on %s is running: [%s] Autentiseringstjenesten 2 0 21 servername.domain 0 37 er ikke tilgjengelig
Cause
AD/LDAP-konfigurasjonen ble utført ved hjelp av SSL-sertifikat(er) (LDAPS). Disse sertifikatene ble importert til Java-forekomsten til NetWorker-serverens cacerts-nøkkellager. Det er et problem med sertifikat(er) som brukes av authc.
Resolution
Hvis du vil se hele fremgangsmåten for konfigurering av LDAPS med NetWorker, kan du se: https://www.dell.com/support/kbdoc/000156132/
Informasjon om konfigurering av LDAPS finnes i veiledningen for NetWorker Security Configuration, som er tilgjengelig via: https://www.dell.com/support/
Prosessen som er spesifikk for sertifikatene, er som følger:
Informasjon om konfigurering av LDAPS finnes i veiledningen for NetWorker Security Configuration, som er tilgjengelig via: https://www.dell.com/support/
Prosessen som er spesifikk for sertifikatene, er som følger:
- Hent rot- og kjedesertifikatene fra LDAP-serveren:
openssl s_client -showcerts -connect LDAP_server_name:636
Merk: I noen miljøer returneres bare ett sertifikat. Hvis flere (kjede) sertifikater returneres, oppretter du imidlertid en individuell .cer som inneholder individuelle sertifikatutdata. Sertifikatene inkluderer ---BEGIN CERTIFICATE--- og ---END CERTIFICATE--- linjer.
- Kontroller nøkkellageret for eventuelle eksisterende sertifikater som er tilknyttet sertifikatet:
/opt/nre/java/latest/bin/keytool -list -keystore /opt/nre/java/latest/lib/security/cacerts -storepass changeit | grep -i LDAP_server_name
A. Hvis noen sertifikataliaser er oppført i nøkkellageret som er tilknyttet LDAP-serveren, fjerner du dem med følgende:
/opt/nre/java/latest/bin/keytool -delete -alias ALIAS_NAME -keystore /opt/nre/java/latest/lib/security/cacerts -storepass changeit
- Legg til de nye kjede- og rotsertifikatene (i den rekkefølgen) i "cacerts"-filen ...
# /opt/nre/java/latest/bin/keytool -import -alias LDAP_server_name_CHAIN -keystore /opt/nre/java/latest/lib/security/cacerts -file /tmp/chain.cer -storepass changeit # /opt/nre/java/latest/bin/keytool -import -alias LDAP_server_name_ROOT -keystore /opt/nre/java/latest/lib/security/cacerts -file /tmp/root.cer -storepass changeit # /opt/nre/java/latest/bin/keytool -list -keystore /opt/nre/java/latest/lib/security/cacerts | grep -i LDAP_server_name Skriv inn nøkkellagerpassord: changeit LDAP_server_name_ROOT, 13. okt 2021, trustedCertEntry, LDAP_server_name_CHAIN, 13. oktober 2021, trustedCertEntry,
- Start NetWorker på nytt:
nsr_shutdown systemctl start networker
- kjør authc_config på nytt
# /opt/nsr/authc-server/bin/authc_config -u Administrator -e update-config -D config-id=2 -D config-active-directory=y -D config-user-dn-password=<PASSORD FOR BRUKER> Skriv inn passord: <Networker ADMINISTRATOR-passord> Configuration SLDAP er oppdatert.
Additional Information
Slik konfigurerer du LDAPS: https://www.dell.com/support/kbdoc/000156132/
Affected Products
NetWorker, NetWorker Management ConsoleArticle Properties
Article Number: 000192505
Article Type: Solution
Last Modified: 10 Jan 2022
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.