Data Domain: Troubleshooting Replication Lag

Summary: This KB article describes how to identify and troubleshoot replication lag. Lag measures how far out of sync two copies of data are. To measure the lag between two contexts, use the replication status command. ...

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Symptoms

 This KB article describes how to identify and troubleshoot replication lag.

  • Lag = how far out of sync two copies of data are
    • To measure the lag between two contexts, use the replication status command.

Symptoms:

  • Replication has lag

  • Cleaning not recovering disk space

  • Cleaning is taking too long

Cause

MTree/Directory Replication is bandwidth optimized (as minimum network usage as possible).


The bandwidth usage depends on the number of unique segments that must be replicated between source and destination systems.

Resolution

The following steps are ordered in the most appropriate sequence to resolve replication lag. Do not skip any step.

  1. Verify that replication is working
    • KB: Data Domain - Replication Status.  
    • Replication may be mis-configured, or external issues exist on the network between the source and destination systems.
    • If the environment is using Cyber Recovery (CR), Please ensure that CR application is in a healthy state.  Engage the CR support team if needed. 
  2. Verify that the available bandwidth is sufficient to handle the amount of data being replicated
    • Testing Network Bandwidth using the net iPerf Command.
    • If replication appears to be working on both Data Domain systems and there are no issues affecting the network between them, the network may not have enough bandwidth to handle the amount of data the source is trying to push to the destination.
  3. Validate replication throughput based on replication throttle. Note: Replication throttle setting is on an interface level (for example Eth1b) and not per context level.
     Review the throttle schedule.
    # replication throttle show
    Verify that the required throttle settings are in place.
  4. View the Replication Status to see the throttle settings.
  5. #replication status rctx: //#
  6. Factors related to sizing:
    • Daily ingest + Ingest change rate
    • Number of contexts supported on the system
    • File size distribution on the context
    • Compression ratio on context
    • Streams available per context 
    • DD Model
    • Available network bandwidth and network latency
    • Cleaning schedule/throttle and filesystem utilization 
    • Encryption over wire and Encryption at rest
  7. Check that the connection host is pointing to the correct IP address      
     #replication show config rctx://# 
     
  8. Check MTree snapshots size (mrepl issues).
     #snapshot list mtree <mtree path>
  9. Check the size of the files on the Data Domain system:
    • Data Domain - Storage Management: Viewing File Distribution .
    • File sizes on the Data Domain system can affect how and when data is sent from the source to the destination. Too many small files or a few large files can affect the way the replication engine can and will send data. These values vary based on model, operating system version, network capacity, etc.
  10. Verify that the backup application is configured as described in the Integration Guide.
    • The configuration of the backup software itself can affect how the application writes to the Data Domain system, which can have significant performance implications.
  11. Review the Replication Best Practices
  12. Make sure the performance is good:

Note: If the issue persists after following the steps in this article, please contact your contracted support provider.
Upload a Support Bundle (SUB) How to Upload a Support Bundle and Create a service request

Additional Information

 

 

 

 

Affected Products

Data Domain

Products

Data Domain
Article Properties
Article Number: 000034064
Article Type: Solution
Last Modified: 21 Jul 2025
Version:  4
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