OneFS selecteert niet automatisch LIN-gebaseerde taken als deze taken efficiënter kunnen worden uitgevoerd

Summary: OneFS selecteert niet automatisch LIN-gebaseerde taken als deze efficiënter zouden zijn om uit te voeren waar SSD is ingesteld op metadata in plaats van L3-cache.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SSD's op een cluster worden geconfigureerd om te worden gebruikt voor metadata in plaats van L3-cache.

In theorie betekent dit dat taken zoals FlexProtect en AutoBalance sneller en efficiënter zouden werken als hun LIN-equivalenten werden geselecteerd (FlexProtectLIN en AutotBalanceLIN). Dit komt doordat de metadata op de SSD's kunnen worden gebruikt door de job engine. 

De reguliere versies van de taak worden automatisch geactiveerd wanneer OneFS dit vereist in plaats van de LIN-versie.

In de whitepaper over de OneFS job engine staat: 
"Er is ook een AutoBalanceLin-taak beschikbaar, die *automatisch* wordt uitgevoerd in plaats van AutoBalance wanneer het cluster een metadatakopie beschikbaar heeft op de SSD. AutoBalanceLin biedt een versnelde runtime van de taak." 



https://www.delltechnologies.com/resources/en-us/asset/white-papers/products/storage/h12570-wp-isilon-onefs-job-engine.pdfMet PSCALE-104758 is het automatisch onderdeel niet waar.
In plaats daarvan wordt een handmatige configuratie gebruikt.
# isi_gconfig -t job-config jobs.common.lin_based_jobs = True

Cause

Dit is te wijten aan een OneFS codeprobleem.

Resolution

Stel de 'run LIN-based jobs' handmatig in op True in clusterinstellingen.
# isi_gconfig -t job-config jobs.common.lin_based_jobs = True
Overweeg het uitschakelen van niet-LIN-taken.

Affected Products

Isilon, Isilon, Isilon Gen6.5, Isilon Gen6, Isilon SmartPools
Article Properties
Article Number: 000212030
Article Type: Solution
Last Modified: 23 Apr 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.