ECS: Unable to generate the secret key for swift user if the username contains capital letters

Summary: If a Swift user was created prior to ECS 3.8.1.0 with mixed case characters and was not created using the UI, generating a secret key for that user fails. Also, it allows the user to create the same username with all lowercase letters as previous username was saved with mixed letters. ...

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Symptoms

Below errors are seen in the UI:
  1. Error 2000 - Unable to find entity in request URL. Unable to find the entity specified in the URL with the given id TEST2.
  2. User sees two Swift user with same name but differ by sensitivity to case.

Cause

Prior to 3.8.1.0, the Swift user API supports creation of case-sensitive object users due to an issue that creates two users with the same name but case-sensitive manner. Example: 'Dell' and 'dell' becomes two unique users.

The same was not true for Swift user creation through UI. UI converts username to lowercase before it calls the API. This secret key generation for these two users maps to the same secret key as system converts all users to lowercase before generating the secret key.

Resolution

If a Swift user with mixed letter created prior to ECS 3.8.1.0 exists, do the following to resolve the issue:
  1. Delete the Swift user with uppercase letters.
  2. Create a new user with lowercase letters.

Affected Products

ECS, ECS Appliance
Article Properties
Article Number: 000223725
Article Type: Solution
Last Modified: 05 Apr 2024
Version:  1
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