Avamar: Falha na restauração de imagem do VMware "Timeout on wait for spawned restore metadata"

Summary: Falha na restauração de imagem VMware com "Timeout on wait for spawned restore metadata avtar process to complete"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A restauração da imagem do VMware para uma nova máquina virtual ou a restauração da imagem para o novo disco falha com o seguinte erro:
 

avvcbimage Error <0000>: [IMG0011] Timeout on wait for spawned restore metadata avtar process to complete


Ao restaurar para uma nova VM ou disco, o fluxo de trabalho normal de restauração deve executar uma "minirrestauração" dos arquivos de configuração da VM a partir do backup selecionado pelo usuário. Esses arquivos são rotulados como arquivos descritores .vmx e .vmdk.

Depois que os dados são restaurados, o proxy assume a configuração da VM restaurada e cria um novo disco virtual da VM. Em seguida, ele pode prosseguir com a restauração da imagem do disco virtual. O trabalho de minirrestauração chamado de "restauração de metadados" tem um tempo de espera excedido padrão de 5 minutos. Como a restauração do VMX é pequena (normalmente ~15 kb), a restauração deve levar apenas alguns segundos.   

No entanto, onde esse comportamento ocorre no log de restauração que vemos: 

1. 2017-04-14 12:50:21 avvcbimage Info : Process 4486 (/usr/local/avamarclient/bin/avtar) for workorder MOD-1492174248297#99 started
2. 2017-04-14 12:55:21 avvcbimage Error : [IMG0011] Timeout on wait for spawned restore metadata avtar process to complete
3. 2017-04-14 12:59:51 avvcbimage Info : Process 4486 (/usr/local/avamarclient/bin/avtar) finished (code 0: success)


As mensagens de log mostram que o tempo total gasto foi de 9 minutos e 30 segundos, mas, por fim, a restauração de metadados foi bem-sucedida. No entanto, a tarefa de restauração de imagem falhou porque o tempo padrão do subprocesso de 5 minutos ou 300 segundos foi excedido.

Cause

O Data Domain é configurado com um grupo de interface (ifgroup) que informa ao cliente ddboost (avtar) para se conectar a uma interface. Essa interface está sendo bloqueada entre o client (proxy)

Na linha de comando ou na página da Web do Data Domain, analise as configurações do DD. 
Configurações de exemplo: 

sysadmin@ddve# Ifgroup Show Config
Group-name   Status    Interfaces
----------   -------   ----------
default      enabled   192.168.69.80
----------   -------   ----------

sysadmin@ddve  net show config
ethV0     Link encap:Ethernet  HWaddr 00:50:56:98:A6:66
          inet addr:10.240.196.80  Bcast:10.240.196.255  Mask:255.255.255.0


ethV1     Link encap:Ethernet  HWaddr 00:50:56:98:56:8F
          inet addr:192.168.69.80  Bcast:192.168.69.255  Mask:255.255.255.0

In the example above the default Ifgroup  setting will cause the client to initially connect to primary/management interface of 10.240.196.80 but will see the ifgroup settings and try to connect with 192.168.69.80.

RPC has a default time-out value of 180 seconds but the client will try multiple times (3 in this case) which would add up to a total of 540 seconds or 9.5 mins.  After trying three times the connection will fallback to 10.240.196.80 but by this time the image restore job would have timed out.   

From the proxy run this series of commands to confirm the issue replacing the IP addresses as appropriate: 
  1. rpcinfo -p 192.168.69.80 (command stops responding for 3 min) 
  2. rpcinfo -p <data domain fully qualified  hostname> 
  3. rpcinfo -p 10.120.24.49   

Resolution

Resolução
Abra a conexão entre as interfaces ifgroup do client e do Data Domain.
Outra opção é desabilitar o ifgroup.

Solução alternativa:
aumente o valor do tempo de espera excedido do subprocesso, por exemplo, para 10 minutos (600 segundos). Isso permite que a restauração seja concluída.  
Para fazer isso, adicione um parâmetro --subprocesstimeoutsecs=600 ao avvcbimageAll.cmd arquivo, localizado em /usr/local/avamarclient/var/ No proxy

Para obter mais informações sobre como editar o arquivo avvcmimage.cmd, consulte 

Additional Information

Artigo relacionado: Avamar — falha na restauração da imagem da VMware com o erro FATAL "GetDiskAttributed Failed" (pode ser necessário fazer login no Suporte Dell)
 

Affected Products

Avamar Client for VMware

Products

Avamar, Avamar Client
Article Properties
Article Number: 000063666
Article Type: Solution
Last Modified: 10 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.