PowerVault ME4, ME5: Samsung SSD Drive Models on Firmware DSG5 or DWG5 May Go Offline

Summary: PowerVault ME administrators are advised to update Samsung SSD drive models on firmware DSG5 to DSG8 (or later) and drive models with firmware DWG5 to DWG8 (or later) to resolve an issue that may cause multiple drives to go offline, potentially leading to disk groups becoming offline in a quarantine state. Applying drive firmware updates requires a maintenance window, in addition, this specific drive update requires the array to be shut down. ...

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Symptoms

Either of the following SCSI sense key codes may be returned when reviewing drive failure events in PowerVault ME event history with the Samsung SSD drive models on DSG5 or DWG5 firmware: 

0x3, 0x11, 0x0 or else 0x4, 0x29, 0x4
An error was reported by a disk drive. (disk: channel: 0, ID: 18, SN: S6LBNA0W108047, enclosure: 0, slot: 18) (Key,Code,Qual,UEC:0x3,0x11,0x0,0x0000) (CDB:880000000000000002f8000000080000)(Info:0x000002F8)(CmdSpc:0x0, FRU:0x0, SnsKeySpc:0x0)(Medium Error, unrecovered read error)   
    
An error was reported by a disk drive. (disk: channel: 1, ID: 8, SN: , enclosure: 0, slot: 8) (Key,Code,Qual,UEC:0x4,0x29,0x4,0x0000) (CDB:1a081c008000)(Info:0x0010005C)(CmdSpc:0x0, FRU:0x0, SnsKeySpc:0x0)(Hardware, device internal reset)

If a disk group in the array is offline in a quarantine state, contact Dell technical support for assistance

Cause

The following cumulative fixes are contained in firmware revisions DSG8 and DWG8:
  • SAS4 Signal Integrity improvements for 16G
  • Two Fixes for 2004-04-29 firmware assert conditions on Power On Reset and IT Nexus loss testing
  • Two Fixes for firmware assert that occurred during reset testing
  • Two Fixes for firmware assert conditions during Write same testing with cancels injected
  • Resolved a timeout condition during link down error injection testing
  • Resolved low likelihood cases where false Unrecovered Errors could occur on NAND read
  • Resolved an issue where Background-Extended Drive Self-test could exceed the 30 minute spec limit

Resolution

On affected drive models, update the drive firmware from DSG5 to DSG8 or later and DWG5 to DWG8 or later versions.

Drive model  Dell Part Number   Drive capacity   Affected firmware   Firmware update 
Samsung PM1653 Series
MZILG960HCHQAD3 H8DG4 960 GB DSG5 DSG8
MZILG1T9HCJRAD3 NRR34 1.92 TB DSG5 DSG8
MZILG3T8HCLSAD3 9N32F 3.84 TB DSG5 DSG8
Samsung PM1655 Series
MZILG1T6HCJRAD3 5RJND 1.60 TB DWG5 DWG8

 


PowerVault ME series administrators must schedule a maintenance window to apply disk firmware updates. For more information about applying updates, select the relevant article for your PowerVault ME4 or ME5 array.

 

Warning: This specific drive firmware update requires the administrator to shut down the array and power on to complete the drive firmware update.

Additional Information

Dell Technologies recommends PowerVault ME array administrators configure SupportAssist to receive notification of available drive and controller firmware updates.


Dells APEX AIOps Infrastructure Observability (formerly known as CloudIQ) service is an optional, free to use for administrators of Dell infrastructure products such as PowerVault and PowerEdge systems covered by ProSupport or ProSupport+ warranty.

Did you know PowerVault ME series array administrators can remotely monitor array health, capacity consumption, and report on I/O performance trends using a secure Internet browser or smartphone app. More information about the service is outlined in this whitepaper:  Dell APEX AIOps Infrastructure Observability: A Detailed Review 

To use this service, PowerVault administrators must:

Affected Products

Dell EMC PowerVault ME4012, Dell EMC PowerVault ME4024, Dell EMC PowerVault ME4084, PowerVault ME5012, PowerVault ME5024, PowerVault ME5084
Article Properties
Article Number: 000219891
Article Type: Solution
Last Modified: 08 Nov 2025
Version:  6
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