PowerFlex-importverktøy – feil i PFxM Kunne ikke create_ldap_user under implementering

Summary: Uten LDAP-konfigurasjon på plass mislykkes PowerFlex Manager under implementeringen og kan ikke create_ldap_user og implementeringen mislykkes.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Scenario

 Kundeinformasjon importeres til PFxM ved hjelp av et PowerFlex-importverktøy. Implementering er forsøkt. Implementeringen mislykkes med ldap-feil. Fra deployment.log:

ERROR [2024-08-05T17:21:41.107092] 75572: type/server.rb:3920:in `create_ldap_user': rackserver-2s6rm34: Could not create_ldap_user NoMethodError: undefined method `downcase' for nil:NilClass

Fra tilsvarende exception.log:

#
  
/opt/asm-deployer/lib/asm/type/server.rb:3921:in `create_ldap_user'
/opt/asm-deployer/lib/asm/type/server.rb:2518:in `provision_server!'
/opt/asm-deployer/lib/asm/service_deployment.rb:5530:in `process_server_with_types'
/opt/asm-deployer/lib/asm/service_deployment.rb:3171:in `process_server'
/opt/asm-deployer/lib/asm/service_deployment.rb:1539:in `block in create_component_thread'

 

Innvirkning

Kan ikke distribuere ressursgruppe.

Cause

Feil i PowerFlex-importverktøyet som er eldre enn 4.2.0. Hvor det var import av legitimasjon med feil brukernavn. Det var å bruke root / admin / secadmin og det var også å plassere ordet NULL i domenet feltet. Dermed kaster PFxM-automatisering inn i LDAP-konfigurasjonskodesekvensen  

Resolution

Slett legitimasjon og opprett dem på nytt manuelt ved hjelp av brukergrensesnittet.  

Et annet alternativ er å oppgradere PowerFlex Import Tool 4.2.0 eller nyere.

Påvirket versjon 

Alle PFxM-versjoner

Fast versjon

PFxM → I/T

PowerFlex-importverktøy 4.2.0

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000269022
Article Type: Solution
Last Modified: 26 Feb 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.