PowerFlex 4.X: SMART_AGGREGATED_STATE_FAILED — urządzenie DAX — SIO03.02.0000013

Summary: PowerFlex zgłasza, że jedno z urządzeń DAX jest bliskie awarii i należy je wymienić. Błędy pamięci NVDIMM, które można naprawić, mogą spowodować, że urządzenie DAX będzie wyświetlane w systemie PowerFlex jako "Failed Now", choć tak naprawdę nie jest ono uszkodzone. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ten błąd jest zwykle wyzwalany w przypadku standardowego urządzenia PowerFlex. W tym przypadku zalecanym działaniem będzie wymiana dysku, jednak w tym artykule wyjaśniono dodatkowe czynności rozwiązywania problemów, jeśli dane urządzenie jest urządzeniem DAX, które jest modułem NVDIMM, a nie dyskiem.


PowerFlex zgłasza poniższy alert, zauważając, że jedno z urządzeń DAX jest bliskie awarii lub działa z obniżoną wydajnością. Znajduje to również odzwierciedlenie w formie alertu DialHome:

 

SIO03.02.0000013
Dysk może ulec awarii lub działać z obniżoną wydajnością.    

SMART_AGGREGATED_STATE_FAILED_NOW Karta charakterystyki.
Device.SMART_Aggregated_State_Failed_Now Zalecane działanie: rozważ wymianę dysku.

 

SMART_AGGREGATED_STATE_FAILED_NOW

Cause

PowerFlex wykrywa, że wystąpił możliwy do naprawienia lub nienaprawialny błąd w jednym z modułów NVDIMM dla węzła pamięci masowej. Po wykryciu błędu generowany jest błąd Smart Aggregated State Failed Now.

Resolution

Oczyszczanie modułu NVDIMM może rozwiązać problem bez wymiany modułu NVDIMM. Wymień moduł NVDIMM tylko wtedy, gdy problem nie ustąpi po oczyszczeniu. 


  • W przypadku węzłów 15G można wyczyścić tylko wszystkie moduły NVDIMM — przed wykonaniem czyszczenia należy usunąć wszystkie urządzenia (urządzenie SDS + urządzenie DAX), aby uniknąć uszkodzenia danych 
  • W przypadku węzłów 14G można wyczyścić tylko jeden moduł NVDIMM lub wszystkie moduły NVDIMM, wykonując poniższe czynności, aby zidentyfikować wadliwy moduł NVDIMM 

 

Weryfikacja awarii

Krok 1: W programie PowerFlex Manager przejdź do sekcji Block > Devices

 

Krok 2: Zaznacz pole kolumn w prawym górnym rogu i dodaj do listy pozycję "Stan S.M.A.R.T".

 

Stan S.M.A.R.T

 

Krok 3: Przejrzyj listę urządzeń dax i sprawdź, czy istnieją jakieś z komunikatem "Failed Now"

 

Nie udało się teraz

 

 

Krok 4: Dla każdego urządzenia DAX w stanie "Failed Now" określ, któremu systemowi SDS odpowiada język DAX, i zaloguj się do kontrolera iDRAC.

 

Krok 5: Sprawdź, czy w dziennikach cyklu eksploatacji dla każdej pamięci NVDIMM odnotowano możliwe do naprawienia błędy.

  • Możliwe do skorygowania błędy pamięci w modułach NVDIMM mogą spowodować, że urządzenie DAX wyświetli komunikat "Failed Now" w systemie PowerFlex, mimo że nie uległo awarii.

 

Dzienniki cyklu eksploatacji.

 

 

Krok 6: Połącz się z podstawowym rozwiązaniem MDM dla odpowiedniego klastra za pomocą protokołu SSH i uruchom następujące polecenia. Służy do sprawdzania kondycji języka DAX, informacji o gnieździe i SN modułu NVDIMM, co wskazuje na niepowodzenie:

  • Zaloguj się do głównego rozwiązania MDM przy użyciu loginu administratora. Używaj pojedynczych cudzysłowów ' ', jeśli hasło zawiera znaki specjalne
    scli --login --username admin --password '<password>' --management_system_ip <pfmp_ip>

  

 

  • Uruchom następujące polecenie, aby wyświetlić szczegółowe informacje o wszystkich serwerach SDS:
scli --query_all_sds

  

Example:

SDS ID: 2e400d3800000004 Name: LAB10_SDS3 State: Connected, Joined IP: XXX
SDS ID: 2e400d3700000003 Name: LAB10_SDS2 State: Connected, Joined IP: XXX
SDS ID: 2e400d3600000002 Name: LAB10_SDS4 State: Connected, Joined IP: XXX
SDS ID: 2e400d3500000001 Name: LAB10_SDS1 State: Connected, Joined IP: XXX
SDS ID: 2e400d3400000000 Name: LAB10_SDS5 State: Connected, Joined IP: XXX

 


  
  • Zlokalizuj serwer SDS, którego dotyczy problem, i zanotuj nazwę serwera SDS, a następnie uruchom następujące polecenie
scli --query_sds --sds_name <sds name>
  • Zanotuj ścieżkę urządzenia dla wszystkich urządzeń dla tego serwera SDS. Zostanie użyta później podczas dodawania urządzeń z powrotem w kroku 8 
  • Zanotuj identyfikator urządzenia, którego dotyczy problem, a następnie uruchom poniższe polecenie
# scli --query_sds_device_info --device_id <device_id>

Przykładowe dane wyjściowe:

# scli --query_sds_device_info --device_id XXXXX

        Device ID: _________ Name: /dev/dax1.0 Path: /dev/dax1.0

                ScaleIO Device Configuration:

                        Original Path: /dev/dax1.0

                        Acceleration Pool: _________

                        Used for RFcache: no

                        Capacity Limit: 31.4 GB (32107 MB)

                        Device State: Normal

                Physical Device Information:

                        Device Type: UNKNOWN

                        Media Type: NVDIMM

                        Auto Detected Media Type: UNKNOWN

                        Vendor Name: N/A

                        Model Name: nmem2

                        Serial Number: _________

                        Slot Number: B5

                        Firmware Version: N/A

                        Cache Look-ahead: not Active

                        Write Cache: not Active

                        ATA Security: not Active

                        Logical Sector Size: 0 B

                        Physical Sector Size: 0 B

                        Capacity: 0 GB

                        LED Setting: OFF

                Background Device Scanner Information:

                        Scanned: 0 MB

                        Error Fixes: 0

                        Compare Errors: 0

                SMART Information:

                        Aggregated State: FAILED_NOW

                        Temperature State: NEVER_FAILED

                                Current Value: 34 Worst Value: 34 Threshold: 0

                        Media Wearout Indicator State: NEVER_FAILED

                                Current Value: 95 Worst Value: 95 Threshold: 5

                RAID Controller Information:

                        Serial Number: N/A

                        RAID vDisk Status: N/A

                        RAID vDisk Type: N/A

                        RAID vDisk Cache: N/A

 

 

Krok 7: Po zidentyfikowaniu, który język DAX odpowiada zanotowanemu modułowi NVDIMM, postępuj zgodnie ze standardową procedurą, aby wyczyścić moduły NVDIMM za pośrednictwem kontrolera iDRAC, jeśli błędy można naprawić. Postępuj zgodnie ze standardowymi wskazówkami dotyczącymi rozwiązywania problemów z modułami NVDIMM, jeśli błędów nie można naprawić.

 

Krok 8: Po oczyszczeniu modułów NVDIMM dodaj urządzenia DAX z powrotem do SDS, a następnie urządzenia PowerFlex zgodnie z wcześniej zanotowaną ścieżką urządzenia, urządzenia DAX będą wyświetlane jako "Nigdy nie uległy awarii". Odpowiedni alert zostanie również automatycznie usunięty z karty Alerty.

Wykonaj kroki 9 i 10 w artykule PowerFlex: Sposób wymiany modułu NVDIMM w węźle PowerEdge 15G i nowszym

Additional Information

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000438714
Article Type: Solution
Last Modified: 30 Jun 2026
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.