AppSync: When an Oracle Database takes over 5 minutes to start in a Red Hat Linux server, AppSync may timeout and fail the recovery.

Summary: If during a Mount and Recover operation of an Oracle Database on a Red Hat Linux server takes over 5 minutes to start up AppSync may time out while waiting. Subsequent unmount jobs will fail for the same reason. ...

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Symptoms

The following error may be seen when doing a Mount and Recover Database operation of an Oracle Database on a Red Hat Linux server either as part of a Service Plan or as an On Demand operation. 
An error occurred while running openDatabase on host <MOUNT HOST>. Refer <UUID>_openDatabase.log on the agent host for more details.
 
The File System will remain mounted and the Oracle DB may actually start. Subsequent unmounts will fail though with the error:
 
An error occurred while running shutdownDb on host <MOUNT HOST>. Refer <UUID>_shutdownDb.log on the agent host for more details.

Cause

This issue is caused by the SSHD session between the AppSync Server and Agent being terminated on by the host the AppSync agent is installed in. This can be confirmed by checking the following entries in the /etc/ssh/sshd_config file. 
 
ClientAliveInterval 5
ClientAliveCountMax 0

These two settings control SSHD sessions and will terminate any session that is inactive longer than the specified time. If they are not present or commented out then the default (seen above) is used. The ClientAliveInterval is the time in minutes before a session is either terminated or a keepalive token is sent. The ClientAliveCountMax is the number of Keepalive tokens that will be sent before a session is terminated.

To work out how long an SSHD session will be open for if there is no activity multiply the two values together. For the default this means that the session will terminate after 5 minutes( 5*0). 

Resolution

To correct this, review the <UUID>_openDatabase.log found in the recovery hosts AppSync plugin log directory (/opt/emc/appsync/logs by default).  This will show how long the database took to start. For a DB that took approximately 20 mins to start the SSHD timeout should be set to 25 or 30 mins. This will allow an overhead for future changes.

Edit the /etc/ssh/sshd_config file with the following changes to have the session remain open for 30 mins:
 
ClientAliveInterval 5
ClientAliveCountMax 6

Following this edit the SSHD should be restarted for the changes to take effect. The host can be rebooted or the following command run to restart SSHD:
 
/etc/init.d/sshd restart

Products

Red Hat Enterprise Linux Version 6, Red Hat Enterprise Linux Version 7, Red Hat Enterprise Linux Version 8
Article Properties
Article Number: 000185055
Article Type: Solution
Last Modified: 12 Dec 2022
Version:  5
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