VxRail: iSM "no está en ejecución", "ejecuta funcionalidad limitada" o "está inactivo (inactivo)"
Summary: El iSM se encuentra en un estado de "no está en ejecución" o "ejecuta funcionalidad limitada". En este artículo, se describen los métodos de resolución.
Symptoms
El módulo de servicio de iDRAC (iSM) es un servicio importante en los hosts para poder recopilar información de iDRAC para el monitoreo.
Esto puede aparecer en iDRAC con el siguiente estado.
Para comprobar el estado del servicio iSM:
Todos VxRail hasta 7.0.x
/etc/init.d/dcism-netmon-watchdog status
8.0+
/etc/init.d/dellism status
Pueden tener uno de los siguientes estados:
- El iSM está activo (en ejecución)
- Este es el estado completamente funcional
- iSM is active (not running)
- El iSM está activo (ejecuta funcionalidad limitada)
- iSM está inactivo (muerto)
Cause
Hay muchas causas posibles de este problema. Un ejemplo es que los servicios en iDRAC no son completamente funcionales, lo que impide que iSM se comunique con ellos.
Cualquier causa raíz individual se debe investigar en una revisión técnica normal (registros, notas de la versión, artículos de la base de conocimientos [KB], etc.) y escalarse según sea necesario mediante procesos estándar (CTE, DE, EE).
Resolution
Para resolver el problema, siga los pasos a continuación:
-
Abra una sesión SSH en cada nodo que tenga el iSM que no ejecuta en IDRAC.
Siga los pasos que se indican a continuación en cada uno de los nodos:
-
En primer lugar, reinicie en frío la iDRAC para reiniciar su sistema operativo. Cada uno de los siguientes métodos es una forma de realizar esta tarea; No es necesariamente ejecutar los tres debido a esto.
/opt/vxrail/tools/ipmitool mc reset cold SSH into iDRAC (same login as web) racadm> racreset hard
-
Detenga el servicio iSM en el nodo.
7.0.x and earlier # /etc/init.d/dcism-netmon-watchdog stop 8.0 # /etc/init.d/dellism stop
-
Instale iSMPKIHelper.
# cd /opt/dell/srvadmin/iSM/bin # ./Invoke-iSMPKIHelper -install
-
Inicie el servicio iSM en el nodo.
7.0.x and earlier # /etc/init.d/dcism-netmon-watchdog start 8.0 # /etc/init.d/dellism start
-
Establezca el servicio de 0 a 1
# esxcli system wbem set -e 0 # esxcli system wbem set -e 1
-
Ejecute el script SupportAssistCollection para recopilar registros de iDRAC
# cd /opt/dell/srvadmin/iSM/bin # ./Invoke-SupportAssistCollection SupportAssist log Collection is in progress.. [||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||]100% Downloading the collected log file is in progress.. SupportAssist Collection logs can be found in path /tmp/TSR20190826xxxxxx_xxxxxx.zip
Si el iSM está "activo (no en ejecución)" y no se puede recuperar mediante "/etc/init.d/dcism-netmon-watchdog restart" o "/etc/init.d/dellism": puede estar relacionado con el siguiente servicio.
Pruebe los siguientes pasos.
/etc/init.d/dcism-netmon-watchdog status /etc/init.d/sfcbd-watchdog stop /etc/init.d/sfcbd-watchdog start /etc/init.d/dcism-netmon-watchdog restart /etc/init.d/dcism-netmon-watchdog status
Los siguientes funcionan igual que los anteriores:
7.0.x y versiones anteriores
/opt/vxrail/tools/ipmitool mc reset cold ; sleep 300 ; /etc/init.d/sfcbd-watchdog stop ; /etc/init.d/dcism-netmon-watchdog stop; /etc/init.d/vxrail-pservice stop; rm /var/run/log/vxps_cache.dat ; sleep 10 ; /etc/init.d/sfcbd-watchdog start ; /etc/init.d/dcism-netmon-watchdog start; sleep 120 ; /etc/init.d/vxrail-pservice start
8.0
/opt/vxrail/tools/ipmitool mc reset cold ; sleep 300 ; /etc/init.d/sfcbd-watchdog stop ; /etc/init.d/dellism stop; /etc/init.d/vxrail-pservice stop; rm /var/run/log/vxps_cache.dat ; sleep 10 ; /etc/init.d/sfcbd-watchdog start ; /etc/init.d/dellism start; sleep 120 ; /etc/init.d/vxrail-pservice start
8.0.3xx:
/opt/platformsvc/bin/ipmitool.sh mc reset cold ; sleep 300 ; /etc/init.d/sfcbd-watchdog stop ; /etc/init.d/dellism stop; esxcli daemon control stop -s platformsvc; rm /var/run/log/vxps_cache.dat ; sleep 10 ; /etc/init.d/sfcbd-watchdog start ; /etc/init.d/dellism start; sleep 120 ; esxcli daemon control start -s platformsvc
Si el estado del iSM es "inactivo (muerto)", reiniciar el servicio del iSM no cambia su estado de inactivo. El intento de quitar, actualizar o instalar a través del iSM genera el siguiente error.
It is not safe to continue. Please reboot the host immediately to discard the unfinished update.
cause = ('DEL-dcism(4.1.0.0.2410-DEL.700.0.0.15843807)', "Failed to unmount tardisk dcism.v00 of VIB DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807: Error in running [rm /tardisks/dcism.v00]:\nReturn code: 1\nOutput: rm: can't remove '/tardisks/dcism.v00': Device or resource busy\n")
vibs = ['DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807']
Please refer to the log file for more details.
[root@nl93vh1012:/tardisks] localcli software vib remove -n dcism
Errors:
[LiveInstallationError]
DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807: Failed to unmount tardisk dcism.v00 of VIB DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807: Error in running [rm /tardisks/dcism.v00]:
Return code: 1
Output: rm: can't remove '/tardisks/dcism.v00': Device or resource busy
Detenga el servicio para que libere su acceso al tardisk anterior. Los procesos de iSM pueden iniciar el respaldo después de esto.
/etc/init.d/sfcbd-watchdog stop
A continuación, puede volver a intentar la actualización o actualizar inmediatamente el iSM manualmente de la siguiente manera:
esxcli software vib update -d /vmfs/volumes/vsan\:*/upgradeBundles-*/<ISM version being upgraded to>.zip
Los lugares donde las carpetas upgradeBundles de vSAN involucran UUID y la versión de ISM depende del destino de la actualización de VxRail.
Si esto no resuelve el problema, es posible que deba drenar la energía del nodo.
Se recomienda probar primero un drenaje de energía virtual, ya que se puede realizar de forma remota. El consumo de energía físico requiere acceso físico.
Dell EMC VxRail: Cómo realizar el drenaje de energía auxiliar remoto del nodo a través de iDRAC (se requiere una cuenta de soporte de Dell para ver este artículo)
Si los problemas continúan, se recomienda comunicarse con el soporte técnico de Dell para obtener ayuda; consulte este artículo de la base de conocimientos.