VxRail : iSM « n’est pas en cours d’exécution », « fonctionnalité limitée en cours d’exécution » ou « est inactif (inactif) »
Summary: L’état de l’iSM est « n’est pas en cours d’exécution » ou « fonctionnalité limitée en cours d’exécution ». Cet article décrit les méthodes de résolution du problème.
Symptoms
L’iDRAC Service Module (iSM) est un service important sur les hôtes pour pouvoir collecter des informations à partir de l’iDRAC à des fins de surveillance.
Cela peut s’afficher dans l’iDRAC comme l’état suivant.
Pour vérifier l’état du service iSM :
Tous les systèmes VxRail jusqu’à la version 7.0.x
/etc/init.d/dcism-netmon-watchdog status
8.0+
/etc/init.d/dellism status
Ils peuvent avoir l’un des états suivants :
- L’iSM est actif (en cours d’exécution)
- Il s’agit de l’état entièrement fonctionnel
- iSM is active (not running)
- L’iSM est actif (fonctionnalités limitées)
- L’iSM est inactif (inactif)
Cause
Il existe de nombreuses causes possibles à ce problème. Par exemple, les services de l’iDRAC ne sont pas entièrement fonctionnels, ce qui empêche l’iSM de communiquer avec lui.
Toute cause première individuelle doit faire l’objet d’une enquête dans le cadre d’une révision technique normale (journaux, notes de mise à jour, articles de la base de connaissances, etc.) et être remontée si nécessaire à l’aide de processus standard (CTE, DE, EE).
Resolution
Pour résoudre ce problème, effectuez les opérations suivantes :
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Ouvrez une session SSH sur chaque nœud sur lequel l'iSM ne s'exécute pas sur iDRAC.
Suivez les étapes ci-dessous sur chacun des nœuds :
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Tout d’abord, redémarrez à froid l’iDRAC pour redémarrer son système d’exploitation. Chacune des méthodes suivantes est un moyen d’accomplir cette tâche ; Il ne s’agit pas nécessairement d’exécuter les trois pour cette raison.
/opt/vxrail/tools/ipmitool mc reset cold SSH into iDRAC (same login as web) racadm> racreset hard
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Arrêtez le service iSM sur le nœud.
7.0.x and earlier # /etc/init.d/dcism-netmon-watchdog stop 8.0 # /etc/init.d/dellism stop
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Installez iSMPKIHelper
# cd /opt/dell/srvadmin/iSM/bin # ./Invoke-iSMPKIHelper -install
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Démarrez le service iSM sur le nœud.
7.0.x and earlier # /etc/init.d/dcism-netmon-watchdog start 8.0 # /etc/init.d/dellism start
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Définir le service de 0 à 1
# esxcli system wbem set -e 0 # esxcli system wbem set -e 1
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Exécutez le script SupportAssistCollection pour collecter les journaux iDRAC
# cd /opt/dell/srvadmin/iSM/bin # ./Invoke-SupportAssistCollection SupportAssist log Collection is in progress.. [||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||]100% Downloading the collected log file is in progress.. SupportAssist Collection logs can be found in path /tmp/TSR20190826xxxxxx_xxxxxx.zip
Si l’iSM est « actif (non en cours d’exécution) » et qu’il ne peut pas être restauré en «/etc/init.d/dcism-netmon-watchdog restart« ou »/etc/init.d/dellism» : il peut être lié au service suivant.
Essayez les étapes suivantes.
/etc/init.d/dcism-netmon-watchdog status /etc/init.d/sfcbd-watchdog stop /etc/init.d/sfcbd-watchdog start /etc/init.d/dcism-netmon-watchdog restart /etc/init.d/dcism-netmon-watchdog status
Les éléments suivants fonctionnent de la même manière que ci-dessus :
7.0.x et versions antérieures
/opt/vxrail/tools/ipmitool mc reset cold ; sleep 300 ; /etc/init.d/sfcbd-watchdog stop ; /etc/init.d/dcism-netmon-watchdog stop; /etc/init.d/vxrail-pservice stop; rm /var/run/log/vxps_cache.dat ; sleep 10 ; /etc/init.d/sfcbd-watchdog start ; /etc/init.d/dcism-netmon-watchdog start; sleep 120 ; /etc/init.d/vxrail-pservice start
8.0
/opt/vxrail/tools/ipmitool mc reset cold ; sleep 300 ; /etc/init.d/sfcbd-watchdog stop ; /etc/init.d/dellism stop; /etc/init.d/vxrail-pservice stop; rm /var/run/log/vxps_cache.dat ; sleep 10 ; /etc/init.d/sfcbd-watchdog start ; /etc/init.d/dellism start; sleep 120 ; /etc/init.d/vxrail-pservice start
8.0.3xx :
/opt/platformsvc/bin/ipmitool.sh mc reset cold ; sleep 300 ; /etc/init.d/sfcbd-watchdog stop ; /etc/init.d/dellism stop; esxcli daemon control stop -s platformsvc; rm /var/run/log/vxps_cache.dat ; sleep 10 ; /etc/init.d/sfcbd-watchdog start ; /etc/init.d/dellism start; sleep 120 ; esxcli daemon control start -s platformsvc
Si l’état de l’iSM est « inactif (inactif) », le redémarrage du service iSM ne modifie pas son état d’inactif. Toute tentative de suppression, de mise à niveau ou d’installation sur l’iSM entraîne l’erreur suivante.
It is not safe to continue. Please reboot the host immediately to discard the unfinished update.
cause = ('DEL-dcism(4.1.0.0.2410-DEL.700.0.0.15843807)', "Failed to unmount tardisk dcism.v00 of VIB DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807: Error in running [rm /tardisks/dcism.v00]:\nReturn code: 1\nOutput: rm: can't remove '/tardisks/dcism.v00': Device or resource busy\n")
vibs = ['DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807']
Please refer to the log file for more details.
[root@nl93vh1012:/tardisks] localcli software vib remove -n dcism
Errors:
[LiveInstallationError]
DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807: Failed to unmount tardisk dcism.v00 of VIB DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807: Error in running [rm /tardisks/dcism.v00]:
Return code: 1
Output: rm: can't remove '/tardisks/dcism.v00': Device or resource busy
Arrêtez le service pour qu’il libère son accès au tardisk ci-dessus. Les processus iSM peuvent ensuite démarrer la sauvegarde.
/etc/init.d/sfcbd-watchdog stop
Ensuite, vous pouvez réessayer la mise à niveau ou mettre à jour l’iSM manuellement immédiatement en tant que :
esxcli software vib update -d /vmfs/volumes/vsan\:*/upgradeBundles-*/<ISM version being upgraded to>.zip
Lorsque les dossiers vSAN upgradeBundles impliquent des UUID et que la version ISM dépend de la version VxRail sur laquelle la mise à niveau est effectuée.
Si cette opération ne résout pas le problème, vous devrez peut-être mettre le nœud hors tension.
Il est recommandé d’essayer d’abord une décharge électrique virtuelle, car cela peut être effectué à distance. L’épuisement de l’alimentation physique nécessite un accès physique.
Dell EMC VxRail : Procédure de décharge de l’alimentation auxiliaire à distance d’un nœud via l’iDRAC (un compte de support Dell est requis pour afficher cet article)
Si les problèmes persistent, il est recommandé de contacter le support technique Dell pour obtenir de l’aide. consultez cet article de la base de connaissances.