VxRail: iSM "nie działa", "działa z ograniczoną funkcjonalnością" lub "jest nieaktywny (martwy)"
Summary: Moduł iSM jest w stanie "nie działa" lub ma ograniczoną funkcjonalność. W tym artykule opisano metody rozwiązywania problemów.
Symptoms
Moduł usług iDRAC (iSM) to ważna usługa na hostach, umożliwiająca zbieranie informacji z kontrolera iDRAC na potrzeby monitorowania.
Może się to wyświetlić w kontrolerze iDRAC w następującym stanie.
Aby sprawdzić stan
usługi iSM: wszystkie narzędzia VxRail do 7.0.x
/etc/init.d/dcism-netmon-watchdog status
8.0+
/etc/init.d/dellism status
Mogą mieć jeden z następujących stanów:
- iSM jest aktywny (uruchomiony)
- Jest to stan pełnej sprawności
- iSM jest aktywny (nie działa)
- iSM jest aktywny (działa z ograniczoną funkcjonalnością)
- Moduł iSM jest nieaktywny (martwy)
Cause
Istnieje wiele możliwych przyczyn tego problemu. Jednym z takich przykładów jest to, że usługi na kontrolerze iDRAC nie są w pełni funkcjonalne, co uniemożliwia komunikację iSM z nim.
Każda poszczególna przyczyna powinna zostać zbadana w ramach normalnego przeglądu technicznego (dzienniki, informacje dotyczące wydania, artykuły z bazy wiedzy (KB) itd.) i w razie potrzeby eskalowana przy użyciu standardowych procesów (CTE, DE, EE).
Resolution
W celu rozwiązania tego problemu wykonaj następujące czynności:
-
Otwórz sesję SSH dla każdego węzła, w przypadku gdy iSM nie działa w kontrolerze IDRAC.
Wykonaj następujące czynności dla każdego z węzłów:
-
Najpierw uruchom ponownie kontroler iDRAC na zimno, aby ponownie uruchomić jego system operacyjny. Każda z poniższych metod jest sposobem wykonania tego zadania; Z tego powodu niekoniecznie należy uruchomić wszystkie trzy.
/opt/vxrail/tools/ipmitool mc reset cold SSH into iDRAC (same login as web) racadm> racreset hard
-
Zatrzymaj usługę iSM na węźle.
7.0.x and earlier # /etc/init.d/dcism-netmon-watchdog stop 8.0 # /etc/init.d/dellism stop
-
Zainstaluj iSMPKIHelper
# cd /opt/dell/srvadmin/iSM/bin # ./Invoke-iSMPKIHelper -install
-
Uruchom usługę iSM na węźle.
7.0.x and earlier # /etc/init.d/dcism-netmon-watchdog start 8.0 # /etc/init.d/dellism start
-
Ustaw serwis od 0 do 1
# esxcli system wbem set -e 0 # esxcli system wbem set -e 1
-
Uruchom skrypt SupportAssistCollection, aby zebrać dzienniki kontrolera iDRAC
# cd /opt/dell/srvadmin/iSM/bin # ./Invoke-SupportAssistCollection SupportAssist log Collection is in progress.. [||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||]100% Downloading the collected log file is in progress.. SupportAssist Collection logs can be found in path /tmp/TSR20190826xxxxxx_xxxxxx.zip
Jeśli moduł iSM jest "aktywny (nie działa)" i nie można go odzyskać przez "/etc/init.d/dcism-netmon-watchdog restart" lub "/etc/init.d/dellism": może być związany z następującą usługą.
Spróbuj wykonać następujące czynności.
/etc/init.d/dcism-netmon-watchdog status /etc/init.d/sfcbd-watchdog stop /etc/init.d/sfcbd-watchdog start /etc/init.d/dcism-netmon-watchdog restart /etc/init.d/dcism-netmon-watchdog status
Następująca praca jest taka sama jak powyżej:
7.0.x i starsze
/opt/vxrail/tools/ipmitool mc reset cold ; sleep 300 ; /etc/init.d/sfcbd-watchdog stop ; /etc/init.d/dcism-netmon-watchdog stop; /etc/init.d/vxrail-pservice stop; rm /var/run/log/vxps_cache.dat ; sleep 10 ; /etc/init.d/sfcbd-watchdog start ; /etc/init.d/dcism-netmon-watchdog start; sleep 120 ; /etc/init.d/vxrail-pservice start
8.0
/opt/vxrail/tools/ipmitool mc reset cold ; sleep 300 ; /etc/init.d/sfcbd-watchdog stop ; /etc/init.d/dellism stop; /etc/init.d/vxrail-pservice stop; rm /var/run/log/vxps_cache.dat ; sleep 10 ; /etc/init.d/sfcbd-watchdog start ; /etc/init.d/dellism start; sleep 120 ; /etc/init.d/vxrail-pservice start
8.0.3xx:
/opt/platformsvc/bin/ipmitool.sh mc reset cold ; sleep 300 ; /etc/init.d/sfcbd-watchdog stop ; /etc/init.d/dellism stop; esxcli daemon control stop -s platformsvc; rm /var/run/log/vxps_cache.dat ; sleep 10 ; /etc/init.d/sfcbd-watchdog start ; /etc/init.d/dellism start; sleep 120 ; esxcli daemon control start -s platformsvc
Jeśli stan iSM to "nieaktywny (martwy)", ponowne uruchomienie usługi iSM nie zmienia jej stanu z martwego. Próba usunięcia, uaktualnienia lub instalacji za pośrednictwem iSM prowadzi do następującego błędu.
It is not safe to continue. Please reboot the host immediately to discard the unfinished update.
cause = ('DEL-dcism(4.1.0.0.2410-DEL.700.0.0.15843807)', "Failed to unmount tardisk dcism.v00 of VIB DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807: Error in running [rm /tardisks/dcism.v00]:\nReturn code: 1\nOutput: rm: can't remove '/tardisks/dcism.v00': Device or resource busy\n")
vibs = ['DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807']
Please refer to the log file for more details.
[root@nl93vh1012:/tardisks] localcli software vib remove -n dcism
Errors:
[LiveInstallationError]
DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807: Failed to unmount tardisk dcism.v00 of VIB DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807: Error in running [rm /tardisks/dcism.v00]:
Return code: 1
Output: rm: can't remove '/tardisks/dcism.v00': Device or resource busy
Zatrzymaj usługę, aby zwolniła dostęp do powyższego tardiska. Następnie procesy iSM mogą rozpocząć tworzenie kopii zapasowej.
/etc/init.d/sfcbd-watchdog stop
Następnie można ponowić próbę uaktualnienia lub natychmiast zaktualizować iSM ręcznie w następujący sposób:
esxcli software vib update -d /vmfs/volumes/vsan\:*/upgradeBundles-*/<ISM version being upgraded to>.zip
W przypadku gdy foldery vSAN upgradeBundles obejmują identyfikatory UUID, a wersja ISM zależy od tego, do jakiego uaktualniana jest aktualizacja VxRail.
Jeśli to nie rozwiąże problemu, może być konieczne usunięcie pozostałych ładunków elektrycznych z węzła.
Zaleca się, aby najpierw wypróbować wirtualny pobór mocy, ponieważ można to zrobić zdalnie. Fizyczny pobór mocy wymaga fizycznego dostępu.
Dell EMC VxRail: Jak wykonać zdalne pomocnicze odłączenie zasilania węzła za pośrednictwem kontrolera iDRAC (do wyświetlenia tego artykułu wymagane jest konto pomocy technicznej firmy Dell)
Jeśli problemy nie ustąpią, zaleca się skontaktowanie się z działem pomocy technicznej firmy Dell w celu uzyskania pomocy. zapoznaj się z tym artykułem bazy wiedzy.