PowerEdge: iDRAC Service Module logs WMI warnings in Windows event log due to ismserviceprovider

Summary: iDRAC Service Module may log WMI warning events in the Windows System event log during registration of "ismserviceprovider"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After installation or service start of iDRAC Service Module (iSM) 3.6 and older the following warning events may be logged in the Windows System event log:

ProviderName : Microsoft-Windows-WMI
Id : 63 
Message : A provider, ismserviceprovider, has been registered in the Windows Management Instrumentation namespace Root\CIMV2\DCIM to use the LocalSystem account. This account is privileged and the provider may cause a security violation if it does not correctly impersonate user requests. 

If Dell OpenManage Server Administrator (OMSA) is also installed, these events may be logged every five hours.

Cause

iSM installs a WMI provider library to provide the iDRAC Hard Reset and system PowerCycle features. The provider must have LocalSystem privileges to access the iDRAC using the IPMI driver. The warning occurs anytime the DSM iDRAC Service Module service is started, and ismserviceprovider is registered with WMI service. Windows provides this logged warning even though the provider has been fully tested for security by Dell EMC.

If OMSA is also installed, it causes more frequent log warnings. This is due to an OMSA feature that synchronizes the iDRAC clock to the operating system clock every five hours, which cause the iSM to reload its libraries.

Resolution

This issue has been resolved with iSM 4.2.0. In previous versions, the warning events can be safely ignored.

Affected Products

iDRAC Service Module

Products

PowerEdge XR2, Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX5016s, PowerEdge MX740C, PowerEdge MX750c , PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640, PowerEdge XE2420, PowerEdge XE7420, PowerEdge XE7440, PowerEdge XE8545, PowerEdge XE8640, PowerEdge XE9640, PowerEdge XE9680, PowerEdge XR11, PowerEdge XR12, PowerEdge XR4510c, PowerEdge XR4520c ...
Article Properties
Article Number: 000184183
Article Type: Solution
Last Modified: 11 Dec 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.