PowerProtect: Virtual Machine vCenter Assetdetectie mislukt met afsluitstatus ADS0001

Summary: De vCenter Asset-detectie mislukt en de afsluitstatus ADS0001.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

De PowerProtect Data Manager appliance wordt gebruikt om de vSphere-omgeving te beschermen. Het wachtwoord van het geconfigureerde vCenter-gebruikersaccount is gewijzigd en bijgewerkt in de PowerProtect Data Manager-configuratie onder Administration > Credentials > VCENTER. De vCenter Asset-detectie mislukt nu met afsluitstatus ADS0001:

Failed
ADS0001: Virtual machine asset discovery on the vCenter my-vcenter.my-domain.com was unsuccessful.

Virtual machine asset discovery cannot be completed because of unrecoverable error conditions.

Check the connection between PowerProtect Data Manager and vCenter. Verify that the provided credentials are valid. Start a manual discovery to discover all virtual machine assets, or wait for PowerProtect Data Manager to perform the next scheduled discovery. If the issue persists, contact Dell Customer Support.
error.jpg
Afbeelding 1: ADS0001 Foutdetails

 

De export van de detectietaak toont een uitzondering bij het detecteren van de clienttags in de omgeving:
YYYY-MM-DD 12:54:01.740Z INFO [discovery-worker-7] [][][][TRACE_ID:9befe126d52f934c;JOB_ID:943f5ac12f0589d1][] [c.e.b.v.t.c.u.VcenterTagClientFactory.newTagClient(66)] -  my-vcenter.my-domain.com: tag client exists com.emc.brs.vmdm.tag.common.client.VcenterTagClient@39752094 
YYYY-MM-DD 12:54:16.741Z INFO [discovery-worker-7] [][][][TRACE_ID:9befe126d52f934c;JOB_ID:943f5ac12f0589d1][] [c.e.b.v.t.c.u.VcenterTagClientFactory.newTagClient(66)] -  my-vcenter.my-domain.com: tag client exists com.emc.brs.vmdm.tag.common.client.VcenterTagClient@39752094 
YYYY-MM-DD 12:54:31.741Z INFO [discovery-worker-7] [][][][TRACE_ID:9befe126d52f934c;JOB_ID:943f5ac12f0589d1][] [c.e.b.v.t.c.u.VcenterTagClientFactory.newTagClient(66)] -  my-vcenter.my-domain.com: tag client exists com.emc.brs.vmdm.tag.common.client.VcenterTagClient@39752094 
YYYY-MM-DD 12:54:46.742Z INFO [discovery-worker-7] [][][][TRACE_ID:9befe126d52f934c;JOB_ID:943f5ac12f0589d1][] [c.e.b.v.t.c.u.VcenterTagClientFactory.newTagClient(66)] -  my-vcenter.my-domain.com: tag client exists com.emc.brs.vmdm.tag.common.client.VcenterTagClient@39752094 
vmdm-discovery.log: 2023-07-06T12:55:01.742Z ERROR [discovery-worker-7] [][][][TRACE_ID:9befe126d52f934c;JOB_ID:943f5ac12f0589d1][] [c.e.b.v.d.v.v.w.FullDiscoveryWorker.doTagDiscovery(306)] -  vCenter: my-vcenter.my-domain.com: Exception message: Failed to get tag connection after 5 retries.  Error: constructVcenterTagClient, id: 36a52b12-7fc4-5333-9c2b-dc03f32f606d, inventorySourceResourceId: 36a52b12-7fc4-5333-9c2b-dc03f32f606d, vCenterHost: my-vcenter.my-domain.com, error: java.lang.NullPointerException, root cause message: NullPointerException:  
com.emc.brs.vmdm.tag.common.error.VmdmTagException: Exception message: Failed to get tag connection after 5 retries.  Error: constructVcenterTagClient, id: 36a52b12-7fc4-5333-9c2b-dc03f32f606d, inventorySourceResourceId: 36a52b12-7fc4-5333-9c2b-dc03f32f606d, vCenterHost: my-vcenter.my-domain.com, error: java.lang.NullPointerException, root cause message: NullPointerException: 
	at com.emc.brs.vmdm.discovery.tag_discovery.service.impl.AbstractBaseTagDiscoveryService.doAllTagDiscoveryForFullDiscovery(AbstractBaseTagDiscoveryService.java:126)
...
De vmdm.log continue berichten weergeven die aangeven dat het JSON Web Token (JWT) dat wordt gebruikt om te verifiëren bij het vCenter niet kan worden bijgewerkt:
YYYY-MM-DD 15:12:33.955Z WARN [not.a.Spring.bean-1] [][][][TRACE_ID:b92303f0d8aa8b03][] [c.emc.brs.aaa.client.Utils.figureAuthorizationTokenFromJwt(127)] -  Not a JWT token: 00000000-0000-4000-a000-000000000000 
YYYY-MM-DD 15:12:33.955Z INFO [not.a.Spring.bean-1] [][][][TRACE_ID:b92303f0d8aa8b03][] [c.e.b.a.c.SecureMessageAuthenticator.authorizationTokenFromExpiredComponentAccessToken(150)] -  Attempting to identify expired token 
YYYY-MM-DD 15:12:33.956Z WARN [not.a.Spring.bean-1] [][][][TRACE_ID:b92303f0d8aa8b03][] [c.e.b.p.m.PlatformRabbitmqTemplate.checkAuthentication(2127)] -  Discarding Message as it is not Authenticated: The Authorization token was not set. 
YYYY-MM-DD 15:12:33.956Z WARN [not.a.Spring.bean-1] [][][][TRACE_ID:b92303f0d8aa8b03][] [c.e.b.p.m.PlatformRabbitmqTemplate.sendAuthenticationExceptionReply(2429)] -  Request message recieved without reply_to address. 
YYYY-MM-DD 15:12:33.960Z WARN [not.a.Spring.bean-1] [][][][TRACE_ID:b92303f0d8aa8b03][] [c.e.b.p.m.PlatformRabbitmqTemplate.onMessage(2147)] -  Authentication failed when trying to handle message: (Body:'[B@5c382158(byte[617])' MessageProperties [headers={Authorization=Bearer 00000000-0000-4000-a000-000000000000, xDellCorrelationId=TRACE_ID:35bd6f89-4660-4ff3-b923-03f0d8aa8b03;, __TypeId__=***.***.brs.***.***.NotificationMessageBase}, messageId=e2ca4341-92a7-4702-bb0f-fc1db37bea01, type=ActivityState, contentType=application/json, contentEncoding=UTF-8, contentLength=0, receivedDeliveryMode=PERSISTENT, priority=0, redelivered=false, receivedExchange=1e11fbab-3da3-4eeb-b49f-36854bb88228.topics, receivedRoutingKey=***.***.component.***.***.PUT, deliveryTag=20691, consumerTag=amq.ctag-3E7pRqvvETesXsIbx8OrfQ, consumerQueue=***.***.queue]) 

Cause

De PowerProtect Virtual Machine Data Mover (VMDM)-service kon het JSON Web Token (JWT)-token (Authorization JSON) niet bijwerken, maar de hoofdoorzaak is onbekend.

Resolution

Tijdelijke oplossing:
De JWT-tokenberichten werden niet meer gegenereerd na het opnieuw opstarten van de vmdm-service en hierdoor kon de detectie worden voltooid. Start de vmdm-daemon opnieuw op de PowerProtect Data Manager appliance wanneer er geen VMware Protection Jobs worden uitgevoerd.

vmdm restart
Article Properties
Article Number: 000215709
Article Type: Solution
Last Modified: 03 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.